[1.5.4] Widget in CKEditor not Found

Hi there,

I need to place a {{{ TheXWidget }}} in CKEdtior and when I do and publish, I got this in my content page: Error translating widget: invalid component definition, can’t find contentbox.widgets.TheXWidget }
ContentBox is looking only in “contentbox.widget” but is not looking in my layout widgets, do I need to tell ContentBox is a “custom” widget as you do in coldbox plugins?

Note: When I do this in my layout: #cb.widget(‘TheXWidget’)# It renders just fine

Thanks in advance

Felipe Serrano

Core widget

Layout widget

Module widget

Thank you Luis!!!

Have a great weekend! :wink:

Hi Luis,

using {{{widgetname-layoutname}}} doesn’t work either (widgetname dash layoutname)

Have you tried using the widget inserter?

With the triple-mustache syntax, I think the layout syntax is {{{~widgetname}}}

Yes, Joel is right
{{{~widgetname}}} is for layouts


Luis F. Majano
Ortus Solutions, Corp

ColdBox Platform: http://www.coldbox.org
Linked In: http://www.linkedin.com/pub/3/731/483
Blog: http://www.luismajano.com
IECFUG Manager: http://www.iecfug.com

Social: twitter.com/lmajano facebook.com/lmajano

Thanks guys :wink:

Hey Guys,

Using {{{~widgetname}}} is there a way to set some arguments and pasthem to the widgetname.cfc?



Did you try {{{~widgetname arg1=“stuff” arg2=“things”}}}?

And have you tried inserting widgets via the Widget inserter in CKEditor? It will allow you to insert layout widgets, as well as module and core ones as well. Plus, the args are really simple to enter via regular form fields.

Thank you Joel, I have been having issues with Widgets in my Railo 4, they all work, but some how I cannot access them in admin neither CKEditor, for now I’ll keep with your suggestions.

Thanks a lot!

What do you mean by not being able to access them? Are you getting ColdFusion errors, or JavaScript errors?

Coldfusion, (Railo) for example when I reload my App from admin (an hour ago), my whole app just crash now Im not able to do nothing… now

This is what I get now, after my App Reload:

Application Execution ExceptionError Type: railo.runtime.exp.PageRuntimeException : [N/A]

Error Messages: The DSL Definition {ref={null}, scope={variables}, dsl={model}, argName={}, name={activeContent}, value={null}, javaCast={null}, required={false}} did not produce any resulting dependency
The target requesting the dependency is: ‘ORMEntity-cbPage’

Did you upgrade something recently? What was the last thing you did prior to the error?



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

Hi Brad,

I was trying to reload my application since I upload a new widget into it, and some how that occur, but at this moment Im upgrading to 1.5.5, I’ll update you with the result.
You know if there is any documentation coming?

Thanks :slight_smile:


Ok, after upgrading to 1.5.5 the app came back again, and also I can now manage Widgets from the admin… great work.
I’ll check everything up and let you know if I find something.

Thanks again