Colbox app + blogcfc

I am working on redoing my personal site and I have a quick question. Almost my whole site is going to be written using Coldbox (home/about/projects/etc) but my blog is going to be a standalone app using blogcfc. How can can I combine the 2 so /blog is its own application? Just a little confused on how to handle this, any insight is appreciated.


If you just drop BlogCFC in /blog the Application.cfc will make it its own application. You wont need to do anything special.


That worked fine and the home page of blogcfc loads fine but whenever I go into an actual entry ColdBox is taking over for some reason.

I am pretty sure this has something to do with the default route but I am not sure how to tell Coldbox to ignore any requests that start with /blog


Are you using SES ISAPI rewrite with that domain?

You might need to add a rule in there to stop blogCFC from being rerouted back to the main ColdBox application.


Andrew Scott

Andrew has it I think.

You need to add a rewrite rule the stops processing for “^blog” or “^/blog” (depending on which rewrite solution/server you are using). The default urlrewrite filters are mapping /blog to /index.cfm/blog which is kicking off the ColdBox app.

Here is an example of some rules that stop processing for IIS:

And, here is another for Tuckey URLRewrite which I use for my blog hosted by TomCat/Railo which rewrites anything that does not match:

<?xml version="1.0" encoding="utf-8"?> Enable TomCat to have SES links. \.(bmp|gif|jpe?g|png|css|js|txt|pdf|doc|xls|xml|cfc|ico|php|asp)$ ^/(?!cdn|src|railo-context|test|mxunit|remote|monitoring|root)(.*)$ /index.cfm/$1

I am using apache mod_rewrite but I am not sure thats the whole issue…

this url works


but this does not and is caught by ColdBox


if you look in config/routes.cfm you will see the default route. Is that catching the request and trying to do something with it? That would explain /blog does not go through the request.

// Your Application Routes

That’s exactly why I think your rewrite rule is routing the “http://localhost/danvega/blog/2011/5/13/cfObjective-2011-Presentation-code-and-slides” to this: “http://localhost/danvega/index.cfm/blog/2011/5/13/cfObjective-2011-Presentation-code-and-slides” which is why ColdBox is getting it. If you post your .htaccess file, I can add the rule directly or you can just modify an existing rule to include “^/blog” to stop processing. If you are using one of the common .htaccess files you should be able to just append the “/blog” to an entry for “railo-context” or “cfide”.


ok I added that and that worked out…but I just realized that my issues were because of some setup I had in blogcfc. thanks for the help guys!


Can’t wait to see you show us all up with your new site. Would be funny if you snatched all Ben Nadel’s photos and photoshoped your face over his :slight_smile:


You will need something in your rewrite rules to ignore the /blog directory.

RewriteRule ^(blog) - [L]


Andrew Scott