[coldbox:19678] [ColdBox-3.7.0] Not Preserving Form

Hey Guys,
Problem solved but… can you tell me why this is…

I am on Railo 4 and i tried to fwreinit=1 with no avail, however I just restarted the railo service and my issue has gone away. I have confirmed the railo mapping is set to Trusted=“no”?

Very weird.

Do you have a password set?

Hmm, are you sure your reinit worked? Is there a reinit password set? Also, what happens when you try getModel(“providerData.base”) from your handler as a test.

Generally speaking, WireBox will throw an error if it comes across a dependency it can’t resolve, so if ProviderData isn’t defined, that usually means the cfproperty didn’t get processed.

Also, please locally scope your variables.

if that model may be called my multiple threads at the same time, that is bad since results will live in the variables scope by default which is shared by the entire CFC. Instead, do this:

Thanks!

~Brad

ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

or

Ok, everything is working as it should now. Guys I can’t thank you enough for all your help and guidance!