[coldbox:25101] ColdBox 4 Issues installing in sub directory

His original post showed one.

Happy Connecting. Sent from my Sprint Samsung Galaxy S® 5

lol, oops I did miss that.

Hi Guys,

Thanks, the path to Coldbox mapping is correct. There is no server level mapping (new CF install). I tried using expandPath() which worked except I then had to add one for interceptors. Ultimately, it resulted in an error where the tools directory is being looked at like a handler. e.g. Error message The event: tools.myHandler is not valid registered event.

I thought that this would be accounted for automatically but perhaps not. The routes folder should use the value of COLDBOX_APP_MAPPING for setBaseURL() function. Is there somewhere else I can set that?

this.mappings["/coldbox"] = ExpandPath(’/tools/coldbox’);

this.mappings["/interceptors"] = ExpandPath(’/tools/interceptors’);



Hmm, there must be something screwy going on with your server. ColdBox should just work fine.



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

Could be - this is the first time I am using Lucee (Lucee installer). If you are saying that given these settings it should work I will take that on face value and bailout. I am just going to load it on a sub domain and forget about the sub-directory- and try to enjoy my weekend.

Thanks for the super speedy replies.


I don’t think you need to do a mapping for interceptors though.