Coldbox 3.5.0 / ORM Error - org.hibernate.exception.SQLGrammarException

I have a Coldbox based application that I was given to do some updates on and I am getting one of those wonderful little error messages that tells you (me) absolutely nothing. The application is built on Coldbox 3.5.0 and uses the Hibernate ORM. The application runs fine on an ACF10 server with MSSQL. However, on Railo 4.0.4, I am getting the follow message …

Error Type: org.hibernate.exception.SQLGrammarException : 229

Error Messages: could not execute query

The last item in the stack trace is the BaseORMService.cfc from ColdBox which I am all but certain is not the culprit. Going back a couple of entries is the application’s UserService.cfc where it is attempting to get a simple list of User objects based upon some criteria.

this.list( criteria=filter.getAllCriteria() );

I have enabled logging in the ORM settings and the logged select query runs without issue in SQL Server. I have checked all of the table and column names and the case matches the database, so I don’t believe it is a case issue. I stripped the User entity down to the point that only the id property was defined and I am still getting the error. I also tried this with several other business objects in the application and all throw the same error when I attempt to call their respective list method and retrieve data.

On a whim, I copied the entire model folder for the application as it was originally over to another empty web root. I added an Application.cfc file that only set up the ORM with the same settings / database as the original application. In other words - no ColdBox here. In this application root, I can instantiate instances of each entity using the standard ColdFusion ORM functions, retrieve data from the database and save it back without error.

So … ACF 10 works … the model without ColdBox works on Railo … with ColdBox and Railo, I get the above error. Anybody have any clue where to look here?

– Jeff