[coldbox-3.5.3] Problem with CF 10 / CF Builder / Console Log Appender

Hi guys - I am pretty sure this is not a CB issue, but hoping someone may be able ot help.

I recently upgraded all of my dev machines from CF-9 to CF-10 and suddenly it seems that the console in CF Builder no longer works. I am on the latest patched versions of CF-10 standalone and CF Builder standalone and I am having the same issue on my 32b Win 7 Pro and 64-bit Win 7 Pro machines.

I have the CF 10 service set to “manual” and CFB set to startup and stop the CF server - which it does just fine. Where CF-9 would have rather verbose logging in the console upon startup and shutdown, there is nothing logged for a shutdown and only the following line for startup:

[localhost]:(12/13 at 05:13:32) Server is available. Getting server settings.

Now perhaps this is all that CF-10 logs to the console on spinning up and down? But none of my Coldbox apps will log to the console any more. Nothing. So, my assumption is that something is up with CFB 2.0.1 and CF-10 with updater 6? Alternatively, I suppose they could be working and the issue is with Logbox?

I tried the ACF forums first (http://forums.adobe.com/thread/1113052) but don’t seem to be getting anywhere there so thought I’d try here as many (most?) of you log to the console via Logbox and perhaps have seen something like this?

I figure I must be missing a simple setting somewhere, but I am completely baffled.

Thanks - as always - for any help!
Andy

Yeah I have found CF 9/10 very flaky when it comes console logging.

One thing that I have noticed is that it is more likely to log, if CF is not running and started via the console itself, or from CFB. But you already say you are doing this.

I have a bit of time later today and tomorrow, where I will sit down and investigate this a little further for you and see what I can come up with.

As for ColdBox, I think if your using the console log appender all should work. So I will look into this as well.

Just a heads up though, ColdBox applications can’t be debugged using the line debugger. This is not a ColdBox issue but a CF/CFB problem that I have continually asked Adobe to look into, but they seem to not think it a high enough priority.

No I am also wondering if there is some connection between the two, because caching and storing stuff in the application scope seems to break a lot of Applications (Yes NON ColdBox Apps as well), so I will do my best to see if this is the case.

Sorry when I say break, it doesn’t break… Just logging and debugging don’t work well.

Ok it appears that it is broken now.

I run ColdFusion on Windows and struggle to get it to work, options tried.

  1. Stop ColdFusion
  2. Start CFB, select start/stop for server, restart CFB
  3. Run ColdBox application.

And as Above except before running ColdBox application try to stop / restart CF from CFB

Another option remove start/stop from server in CFB, stop ColdFusion and stop CB. Start ColdFusion with bat file, and restart CFB.

Although I see all the logs to the actual console that CF is running, all I see in CFB is the following.

[Local ColdFusion 10]:FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)
[Local ColdFusion 10]:ERROR: transport error 202: bind failed: Address already in use
[Local ColdFusion 10]:ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)
[Local ColdFusion 10]:JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized […/…/…/src/share/back/debugInit.c:690]
[Local ColdFusion 10]:Error(12/14 at 01:57:50) Unable to stop server. Server stop timed out.
[Local ColdFusion 10]:Error(12/14 at 01:57:52) Operation is canceled.

Sounds like a ticket needs to be raised with Adobe on this.