[Coldbox 3.7.0] Using nvarchar field for russion character

Hi All,

Currently, I use coldbox 3.7.0 with ORM enable true and I want to handle russion character such as Афанасий, I have craete the field table with type NVARCHAR

But when I save it to database the value is ???

Any idea for this case?


Warms Regards


I’m not the best at dealing with character set stuff, but have you set a page encoding in your CFML code and are you using the proper character set in your database.



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

I have solve tis problem, just go to coldfusion administrator > datasource > advance setting
and then set this option:

String Format – Enable High ASCII characters and Unicode for data sources configured for non-Latin characters


this can be best solved by creating the database with the right settings.

create database my_new_database default CHARACTER SET = utf8 default COLLATE = utf8_general_ci;

yes you are right