[Coldbox 4.0.0 - BE] cbdebugger bug

There seem to be a few related actually:

If this module is loaded in coldbox,cfc you still cannot seem to disable it via the debugpanel button or URL param… which I thought was fixed in COLDBOX-288?

You can load the module and then set it to false in coldbox.cfc, but for some reason the cachebox panel inline css and javascript still get loaded on the page.

Third - whether debugpanel is on or off, the inline javascript is affecting ajax calls (specifically responses) which is how I noticed #2 above.

Thanks for the report. This is most likely a bug in the new module. Please enter a ticket so we can get it sorted. Pull requests are also welcome.

Thanks!

~Brad

Yes, the module was incomplete.

As of yesterday it is now complete and has some extra features as well (Read the instructions).

You can install it via commandbox: box install cbdebugger

Hi Brad - I am obviously daft, but before posting here I tried to search for how to file a ticket and couldn’t figure it out. I found links to already filed bugs on Atlassian, but when I got there I couldn’t find a way to post my own? I couldn’t seem to login with my Google Account (the one I use for these groups, so wasn’t sure where to go) As I said - I must be daft!

I posted it here after only finding this link that said to do so:
http://www.coldbox.org/support/reportbug

You may want to update that link with instructions on how to login/file a bug! :slight_smile:

Andy

Andy, our instructions for signing up for JIRA and creating tickets are here:
http://blog.coldbox.org/blog/how-to-create-a-jira-account-and-enter-coldbox-tickets

See Luis’ comments earlier today that he has updated the debugger module. He may have already fixed the bugs.

Thanks!

~Brad

ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

thx for the link, Brad - done.

I’ll check out the new bits and see how they fare.

Cheers,
Andy

OK, so the new modules install properly via CommandBox now (yeah!), but the debugger still cannot be turned off via the URL or the debugpanel “Turn Debugger Off” button. In fact, it’s a bit more broken now as it used to turn off for the current page/request and then not “stick” but now the URL key and the panel button seem to have no effect.

I mentioned this in a comment on already closed COLDBOX-288 so perhaps that ought to be reopened (assuming that was the same issue).

When the debugger is active it creates some sort of issue with Ajax calls using the jquery dataTables plugin but I have not isolated specifically what that conflict is just yet, so not sure if a CB bug or a namespacing conflict with my code,etc.

Thanks for the report. I reopened the ticket.

Thanks!

~Brad

ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com