[Coldbox 4.1.0] [module nsg-module-google 1.0.5]


Thanks. I guess I’m confused. I’m thinking #entryPoint#/provider/#provider# would be equivalent to

module = #entrypoint#
handler = home
function = auth
rc.provider = #provider#

The error I’m getting is “#entrypoint#.provider is not valid event” which tells me the route is not being honored.

Is that not right?

Thank you!


I am going to ask the obvious, you have reinited the framework.

Feel free to contact me off list with a zip of the module and I will have a quick look at it, but you’re right in what you’re saying. I just wanted to clarify that the route and entrypoint play a part in this as well and that the :provider also needs to be present in the calling url as well.

Do you have commandbox?

If yes try to install this module in a fresh created application, simply add oauth credentials and go to the module entrypoint localhost:{port number}/socialauth.

And report back the error.

On a new app I get a “proper” error

key [USER] doesn’t exist

Since I’m going here - /index.cfm/socialauth - then that’s what I would expect. “socialauth” has been translated to

module - socialite
handler - home
function - index

I have no idea why it’s not doing that on the other site. I’ll look at it some more. The only difference I can see on the other site is I’m using web.config to get rid of “index.cfm”. All my other routes (in the main app) work fine however.


Sorry, I haven’t followed everything in this thread, but if you’re using IIS have you re-installed the web connector? It can cause all kinds of URL-related troubles.



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com


After trying Tropicalista’s idea of a blank app I started stripping the “real” one down bit by bit. Turns out it’s the “setAutoReload” setting in the main app config/routes.cfm. If this is “true” then it appears any routes in modules are busted/ignored. Set it to “false” and they work fine. No idea why that is. Kind of irritating but perhaps there’s a reason. Anyway, I know what it is now.

Thank you.


​Good to know. I wonder why that is, seems like a quirk.​