[coldbox:4239] noob - not processing handler/view

I am new to ColdBox. I have downloaded CF9 and ColdBox 3.0 M5. I am following Jason Dean’s blog posts and have run into a problem. I am at step http://www.12robots.com/index.cfm/2008/11/2/Adding-Todo-Lists–ColdBox-Series-Part-8a where I create a form and a handler. This seems very basic and obvious. However, if the handler does not exist, I do not get the error he suggests. Rather, I get the index page. And, if the handler does exist, I still get the index page. I realize this must be something really basic, but I am not seeing it. I would post code, but don’t have a clue what bits of code would be meaningful. Any pointers or ideas?

Bill

Hi Bill,

I would suggest to watch few ColdBox presentation to understand basic
stuff
http://wiki.coldbox.org/wiki/MediaPresentations.cfm

Thanks
Sana

I have read a bunch of documentation on the site (before the suggestion was made), and have viewed some of these presentations. None of this was of much help. However, after reading http://wiki.coldbox.org/wiki/EventHandlers.cfm and seeing the following:

//No Packages

index.cfm?event=main.index

//With SES routing

index.cfm/main/index

I decided to try reaching my page using the routed path. That seemed to work. It amazes me, though, that the standard url format did not. Perhaps the above documentation should be changed. Here are the various paths I tried, followed by the corresponding view result and resulting view:

http://127.0.0.1:8500/proof/index.cfm?event=Concept INCORRECT - default

http://127.0.0.1:8500/proof/index.cfm?event=Concept.index INCORRECT - default

http://127.0.0.1:8500/proof/index.cfm?Concept.list INCORRECT - default

http://127.0.0.1:8500/proof/index.cfm/Concept CORRECT – index

http://127.0.0.1:8500/proof/index.cfm/Concept/index CORRECT – index

http://127.0.0.1:8500/proof/index.cfm/Concept/list CORRECT – list

Bill

Hi Bill,

I know, Coldbox can be a bit overwhelming at first. At least, it was
for me. But by looking at all the examples and documentation I got the
hang of it, so hang in there, I am sure you will too.

By the look of it, you have SES Interceptor enabled. In your config
file (probably routes.cfm) can you look for the following setting:

setUniqueURLS

If that has a value of true, that would explain the behaviour you
describe. Read more about the SES interceptor here:

http://wiki.coldbox.org/wiki/URLMappings.cfm

If you set the setting to false, en reload the application, it will
accept both kind of URL's.

Hope that helps!

Erik-Jan

Yes that’s the case, by default SES is our preference, instead of ? query string URLs. But be careful about strict mode in SES.

Luis F. Majano
President
Ortus Solutions, Corp

ColdBox Platform: http://www.coldbox.org
Linked In: http://www.linkedin.com/pub/3/731/483
Blog: http://www.luismajano.com
IECFUG Manager: http://www.iecfug.com

Okay, so just to be clear, SES is the default in 3.0 and the old standard way shown in the documentation I referenced below will not work unless I change something? That’s fine, of course. I would prefer to work with the SES version. I just want to be sure that I am not doing something odd causing the former standard way to work.

Bill Turner