coldbox - mapping coldbox to a directory thats not named coldbox

I’ve read all the documentation on this, and am continually stymied by wanting to call the folder a different name other than “coldbox” so i can have multiple versions of coldbox installed
this is my dev machine so i dont want to create a virtual path i have only on ver of cf 11 running

I have the following piece of code in my Application.cfc

this.mappings["/coldbox"] = ExpandPath(’/coldbox4’);

this is for the directory outside the www root

i have tried having the coldbox directory inside the www root and using the following code

this.mappings["/coldbox"] =‘coldbox4’;

I then tried to get an absolute path

this.mappings["/coldbox"] = ‘C:\ColdFusion11\cfusion\coldbox4’;

none of this will work

i get a variety of different types of coldfusion errors, one of which is

Could not find the ColdFusion component or interface C:/ColdFusion11/cfusion/wwwroot/coldbox/system/core/util/RequestBuffer.cfc

have also gotten

Could not find the ColdFusion component or interface LRU.

Any help i can get on this would be greatly appreciated

You should be able to do this no problem. Firstly, make sure you have turned off “component caching” in your ColdFusion administrator (if using ACF) as it will cache CFC paths on you.

Secondly, you want to use fully expanded paths in your mappings like you shows in your last example. I’d test the mapping by dumping expandPath( ‘/coldbox’ ) in your on RequestStart to see if it’s resolving to where you expect it to.

> Could not find the ColdFusion component or interface LRU.

This error usually happens when someone runs a ColdBox app from a folder inside the web root and has the coldbox folder in the sub folder but doesn’t have a working mapping. The initial bootstraps will find the ColdBox folder simply because it’s in the same relative directory, but coldbox.system.etc paths won’t resolve from anywhere else.



ColdBox/CommandBox Developer Advocate
Ortus Solutions, Corp

ColdBox Platform:

thank you, component cache was definately the issue, thank you