ColdFusion Builder 3 and ColdBox Platform Utilities

Do the C.P.U.'s work on CB3? Have I done something wrong installing them? They are there, but I can’t do what you do in the videos… puzzled…

I can’t find CB2 anywhere to download, so I’m puzzled…


Oh you mean the utilities, yeah I did send Luis an IM asking if there are any know issues, but got no response.

Yes it does work no problems

Is there instructions on where things need to go, because it is not working for me. When I go to create a module I get the website and not the CFB handler in a CFB view.

same issue here… I’m obviously doing something wrong…

Can you send a screenshot of what you’re seeing?



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

no coldbox options on right click of folders… only a few options when right click on the body of the page with a cfc open.

Had railo running on my machine, it worked once or twice, then tried another config and it all fell apart like humpty dumpty… then installed CF11 standalone and that’s screwing my whole dev computer to hell, and throwing errors also.

It’s got to be something with the server setup… I can browse to the admin from CFB, but that’s about all I can do, otherwise I get errors from the popup windows when creating the project.

Wish I had the magic you have in the video :wink:

On windows 8, 64 bit

Turns out I’m stupid… was inn projects not ‘Navigation View’

Is it just me or is Eclipse a PITA that needs to be put down…

So wish this was in brackets…

So after half rebuilding my machine, I was in the wrong view… good news, can go back to railo!

Brad no screen shot is necessary, I think it has something to do with the changes in CFB3 and how the project was set up. etc.

To give you a run down this is what is happening for me.

  1. Import extension to the installation folder for ColdFusion this is c:\cfusion\cfusion\wwwroot\ for me
  2. The Web Application is not running as default WebSite or port under IIS.
  3. Project Root is stored d:\ColdFusion\projects\ContentBox2 Testbed\

So when the extension is installed, I then bring up the right Context Menu and select ColdBox modules. CFB3 is running the handler as you can see it doing so in the bottom right corner. After a min ColdFusion Builder 3 throws up a window with the ContentBox 2.0 website.

I am almost 100% certain that something has changed in the way projects are handled in CFB3, so maybe we have missed some fundamental setting that is doing this for us.

Not sure Chris, Eclipse is adaptable to a wide range of things that no other editor is capable of handling at the moment. The only issues I have with ColdFusion Builder is Adobe themselves as they seem to screw things up, remove things and change things that just makes the experience crap.

Like views not opening where they are supposed too open, Adobe don’t care where it opens as long as it opens. Which is an attitude that makes me puke every time with Adobe. I have seen views open the first time in my minimized help view as it was the last focused window when I did something and Adobe are like well it opens don’t it!

it’s that attitude by Adobe that makes Eclipse worse than it actually is.

Not sure what I did wrong with Railo, but it’s working with CF11, so I’m away for this week, will tinker on the weekend to get it working with railo again (should be fine now I have half a clue)

now i’m just getting a error " The method map was not found in component" pointing to …\config\WireBox.cfc when I drop in a module into the advanced template (which unlike the video no longer comes with a modules folder)

it doesn’t like the functions in the ModuleConfig.cfc’s…

I’ll keep on trucking as this seems to be the last obstacle to getting the REST api active (yay!)


I’m on skype as ‘dawesi’ if you have any idea what’s going on here.

Can you provide a full stack trace of the error?



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

turned out to be a corrupted zip download of the framework… all sorted… now I can relax (pun intended) tonight

of course youtube has removed the easter egg video, the one from the relax logo, but I can relax without that…

now to relax further by generating the relax config from the database