coldspring and transfer configuration... am I missing something?

First of all, thanks Luis and the rest of the people involved for such
a nice framework.

I've been testing coldbox for a while, and I have a problem with some
of the examples. These are my settings:

- CF7 server.
- Installed coldspring in virtual server path /coldspring
- Datasource installed fine.
- oracle 10g

When I try to run the simpleblog example number 4 I get the following

Bean creation exception in transfer.TransferFactory
Could not find the ColdFusion Component
transfer.TransferFactory.:Please check that the given name is correct
and that the component exists.:

The error occurred in /isla/coldspring/beans/BeanDefinition.cfc: line
Called from /isla/coldspring/beans/BeanDefinition.cfc: line 384
Called from /isla/coldspring/beans/BeanDefinition.cfc: line 534
Called from /isla/coldspring/beans/BeanDefinition.cfc: line 534
Called from /isla/coldspring/beans/DefaultXmlBeanFactory.cfc: line 731
Called from /isla/coldspring/beans/DefaultXmlBeanFactory.cfc: line 632
Called from /isla/coldspring/beans/DefaultXmlBeanFactory.cfc: line 685
Called from /isla/coldspring/beans/DefaultXmlBeanFactory.cfc: line 216
Called from /isla/coldspring/beans/DefaultXmlBeanFactory.cfc: line 201
Called from /isla/coldspring/beans/DefaultXmlBeanFactory.cfc: line 190
Called from /isla/coldbox/system/plugins/ioc.cfc: line 247
Called from /isla/coldbox/system/plugins/ioc.cfc: line 75
Called from /isla/coldbox/system/services/LoaderService.cfc: line 129
Called from /isla/coldbox/system/services/LoaderService.cfc: line 108
Called from /isla/coldbox/system/services/LoaderService.cfc: line 37
Called from /isla/coldbox/system/coldbox.cfc: line 56
Called from /isla/coldbox/samples/applications/SimpleBlog/

I've read the documentation, but I find little troubleshooting
information. I've tried the same sample with different servers (railo,
openbluedragon) and in different OS, all throw the same error.

Any hints? anything I could try... TIA,


The error says that it can't find TransferFactory.

So do you have a transfer directory in your webroot or did you create
a mapping 'Transfer' which poitns to Transfer?


But isn't transfer included in the extras? I'll install it just in
case... thanks!


Whether it is included in the extras or not doesn’t matter. You still have to either have it in your web root or have a mapping to it. :slight_smile:

no, transfer isn’t included in the extras, what’s in the extras are some utilities that make working with Transfer w/ColdSpring in ColdBox a little easier.


OK. I downloaded transfer-1.1 saved in weroot/transfer, the same as
simple_blog_4, and I get the following CFML Runtime error:
Error including config file: General Runtime Error
Request /simple_blog_4/index.cfm
Detail The file /simple_blog_4/config/routes.cfm could not be located

But the file is there, and is accessible... Any ideas?


What does your directory structure look like?

BTW the last error was produced using bluedragon. My directory
structure is very simple, in my webroot:
- coldbox
- coldspring
- simple_blog_4
- transfer



Where are your application files?

It works! ...well, kind of. It works with railo final,
doesn't with openbluedragon 1.0.1 :frowning:

Thanks! Dutch and Matt for your help,


Now that you have it working, I’ll let you know how I use Transfer.

I’ve been using the Transfer Loader Interceptor to load Transfer, instead of using ColdSpring to load Transfer.

this creates a cached ocm:Transfer object.

From the documentation:
“This declaration will create the following objects in the ColdBox cache and register the TDO Bean Injector Observer.”

Essentially, you can inject/wire any object produced by ColdBox, Lightwire, or ColdSpring into any Transfer object’s decorator (read up on the model integration guide).

To use Transfer in my controllers, I have an EventHandler.cfc in my handler’s directory. Every hanlder I have extends EventHandler.cfc.

I wire Transfer into EventHandler.cfc with:

I then have a getTransfer() function:

Anytime I want to use transfer in my controllers, I simply do getTransfer().