[CommandBox 2.2.0] PostgreSQL Incompatibility with Lucee Version

I just opened a ticket for Lucee which is relevant to the new CommandBox version. Apparently something in Lucee 4.5.2 is incompatible with the PostgreSQL JDBC drivers. Wiping out and re-initializing the .Commandbox directory had no effect. Rolling back to CommandBox 2.0.0+0009 resolved the issue by downgrading Lucee to


Just thought I’d post this here, in case anyone using PostgreSQL was planning on upgrading to Box 2.2.

P.S. Love the new Homebrew installation options! Thanks!

Thanks for the note Jon. I saw your message in the Lucee channel on CFML Slack and I saw the ticket come through on the Lucee JIRA. If necessary, we may have to roll CommandBox back to a stable version of Lucee. I didn’t realize originally that we were grabbing an unstable version.



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

I hadn’t tested 4.5.2 yet, so I was surprised it suddenly didn’t work. I walked back through the CommandBox versions one-by-one until I found one that worked, which was Lucee 4.5.1.

I tried swapping out all of the the Postgres drivers between 8.4 and 9.4 and all were throwing errors. Once I rolled back to 4.5.1, I saw that the they were still using the 8.3 driver.

Per my note in the ticket, swapping out .Commandbox/lib/postgresql-9.1-901.jar with the 8.3 JDBC4 driver from PostgreSQL JDBC Download , solves the problem.