ContentBox installation issue on CF2018 + Apache Web Server

Hi all,

i’ve created a virtual folder in Apache for ContentBox, this is my vhost conf:

<VirtualHost *:443>
	ServerName contentbox4.iln.local                                
	DocumentRoot "/Applications/ColdFusionBuilder2018/ColdFusion/cfusion/wwwroot/domini/contentbox4"
	<Directory "/Applications/ColdFusionBuilder2018/ColdFusion/cfusion/wwwroot/domini/contentbox4">
		Options Indexes FollowSymLinks
		AllowOverride All
		Require all granted
	JkMountFile "/Applications/ColdFusionBuilder2018/ColdFusion/config/wsconfig/1/"
	SSLCertificateFile      /Users/andrea.veggiani/_wildcard.iln.local.pem
	SSLCertificateKeyFile   /Users/andrea.veggiani/_wildcard.iln.local-key.pem

I’ve installed Contentbox in the contentbox4 folder with CommandBox; if i start CF 2018 from the Commandbox server all is fine and i can get correctly the installer at the url:

If i run in my browser the url:


i got a page with this output:

Welcome to ContentBox Modular CMS!

What can be the issue?

Thanks for your help.

Andrea Veggiani

@bdw429s can you assist? Thoughts?

I don’t understand the issue.

i got a page with this output:

Welcome to ContentBox Modular CMS!

Is that… not what you wanted?

No, i’m expecting to have cbinstaller served, like per url:


The issue is that if i run it from the commandbox launched server it work well; if i run it from an external CF with Apache connector it does not work presenting as output:

Welcome to ContentBox Modular CMS!

instead of the cbinstaller interface.

Thanks for your support.

Sorry, but I have no idea what all that means, lol. I need screenshots or something. I first guess is you have an issue with rewrites or path_info not being setup on your external web server. It’s been several years since I’ve even installed ContenBox, so I’m not really familiar with what screens you’re seeing or expecting to see. I can help with the web server setup, but I need a better description of what the issue is without the ContentBox details.

I think what he is saying is that via CommandBox it works great,but once you add Apache, then the SES URlS don’t work. I am suspecting his apache connector is not handling the SES urls.

Well, that’s what I said too, so at least we’re on the same page :slight_smile:

Hi all; in order to better undertstand the issue i abandoned the use of commandbox at all and i’ve inspected the behavior of Contentbox in my CF2018 + Apache environment.

I restarted from scratch and i got many errors related to ‘not found’ resources like this:

"conbox","Directory does not existDirectory: /Applications/ColdFusionBuilder2018/ColdFusion/cfusion/wwwroot/modules/contentbox/modules/contentbox-ui/models

My installation root:


CF2018 wwwroot:


I’ve found that the /coldbox/system/ioc/config/Binder.cfc in the mapDirectory method has this line:

**var** targetDirectory = expandPath( "/#replace( arguments.packagePath, ".", "/", "all" )#" );

And sometimes it resolve not to the app root but to the CF 2018 root, i guess it’s an expandPaht issue?

Trying to force a replace like this:

targetDirectory = replace(targetDirectory,'/Applications/ColdFusionBuilder2018/ColdFusion/cfusion/wwwroot/','/Users/andrea.veggiani/cfapps/conbox/');

apparently make things work; any suggestion?

Thanks for your support.

ps: my .htaccess is:

RewriteEngine on

#if this call related to adminstrators or non rewrite folders, you can add more here.

RewriteCond %{REQUEST_URI} ^/(.*(CFIDE|cfide|CFFormGateway|jrunscripts|railo-context|lucee|mapping-tag|fckeditor)).*$

RewriteRule ^(.*)$ - [NC,L]

#Images, css, javascript and docs, add your own extensions if needed.

RewriteCond %{REQUEST_URI} \.(bmp|gif|jpe?g|png|css|js|txt|xls|ico|swf)$

RewriteRule ^(.*)$ - [NC,L]

#The ColdBox index.cfm/{path_info} rules.

RewriteRule ^$ index.cfm [QSA,NS]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*)$ index.cfm/%{REQUEST_URI} [QSA,L,NS]