Error installing ContentBox on Hostek with Adobe ColdFusion 2021

I tried to install Content Box CMS on my host (Hostek), they had an installer. They tell me that I need to use Lucee and not ACF. Is this true? I get a nasty error:

at cfBuilder2ecfc533687992$funcBUILDCFC.runFunction(D:/home/ at cfInjector2ecfc1777318116$funcBUILDINSTANCE.runFunction(D:/home/ at cfNoScope2ecfc460839901$funcGETFROMSCOPE.runFunction(D:/home/ at cfInjector2ecfc1777318116$funcGETINSTANCE.runFunction(D:/home/ at cfLoader2ecfc506566234$funcSETUP.runFunction(D:/home/ at cfModuleConfig2ecfc1077531618$funcONLOAD.runFunction(D:/home/ at cfModuleService2ecfc1979165563$funcACTIVATEMODULE.runFunction(D:/home/ at cfModuleService2ecfc1979165563$funcACTIVATEALLMODULES.runFunction(D:/home/ at cfLoaderService2ecfc162667661$funcLOADAPPLICATION.runFunction(D:/home/ at cfBootstrap2ecfc11787530$funcLOADCOLDBOX.runFunction(D:/home/ at cfApplication2ecfc1857985566$funcONAPPLICATIONSTART.runFunction(D:/home/

coldfusion.runtime.CustomException: Error building: jl@cbjavaloader -> java.lang.reflect.InaccessibleObjectException: Unable to make public void jdk.internal.loader.BuiltinClassLoader.loadModule(java.lang.module.ModuleReference) accessible: module java.base does not "exports jdk.internal.loader" to unnamed module @566c1e71  with constructor arguments: {compileDirectory={D:\home\\wwwroot\modules\contentbox\modules\contentbox-deps\modules\BCrypt\modules/cbjavaloadermodel/javaloader/tmp},trustedSource={false},loadPaths={[]},loadColdFusionClassPath={false},parentClassLoader={},sourceDirectories={[]}}
	at coldfusion.tagext.lang.ThrowTag.doStartTag(
	at coldfusion.runtime.CfJspPage._emptyTag(
	at cfBuilder2ecfc533687992$funcBUILDCFC.runFunction(D:\home\\wwwroot\coldbox\system\ioc\Builder.cfc:132)
	at coldfusion.runtime.UDFMethod.invoke(
	at coldfusion.filter.SilentFilter.invoke(
	at coldfusion.runtime.UDFMethod$ReturnTypeFilter.invoke(
	at coldfusion.runtime.UDFMethod$ArgumentCollectionFilter.invoke(
	at coldfusion.filter.FunctionAccessFilter.invoke(
	at coldfusion.runtime.UDFMethod.runFilterChain(
	at coldfusion.runtime.UDFMethod.runFilterChain(
	at coldfusion.runtime.UDFMethod.invoke(
	at coldfusion.runtime.TemplateProxy.invoke(
	at coldfusion.runtime.TemplateProxy.invoke(
	at coldfusion.runtime.TemplateProxy.invoke(
	at coldfusion.runtime.CfJspPage._invoke(
	at coldfusion.runtime.CfJspPage._invoke(
	at cfInjector2ecfc1777318116$funcBUILDINSTANCE.runFunction(D:\home\\wwwroot\coldbox\system\ioc\Injector.cfc:290) I am using content-box 5, MySQL 8. I hoe that you can see the error, it’;s too long to display here.

Thanks so much for any help!

@johnbarrett Please post the error here in your thread. The link above doesn’t even load for me and we want it for historical purposes.

Can you clarify what you mean by this? What “installer” did they use.

This may be part of the issue. I’m just guessing, but I’ve seen a lot of people having troubles connecting to the newer MySQL versions.

Not that I’m aware of. @lmajano

Ok, the site is loading now so I added the error to your post. What version of Java is the site running on? This is a very low level error coming from Java itself.

Here is the whole error, and thanks so much for your help!

Error building: jl@cbjavaloader → java.lang.reflect.InaccessibleObjectException: Unable to make public void jdk.internal.loader.BuiltinClassLoader.loadModule(java.lang.module.ModuleReference) accessible: module java.base does not “exports jdk.internal.loader” to unnamed module @566c1e71 with constructor arguments: {compileDirectory={D:/home/},trustedSource={false},loadPaths={[]},loadColdFusionClassPath={false},parentClassLoader={},sourceDirectories={[]}}

That is not the “whole” error :slight_smile: Always post the full stack trace all the way down to the bottom. Now, you may note when I edited your post above I didn’t do that, but I also knew by looking at it in this case that all the useful info was at the top. But in general, always post the full stack trace leaving nothing out.

It won’t let me copy everything, it’s too long it says. Here is a pdf of the full trace -

Hmm, that sounds like maybe a security sandbox issue maybe? @bdw429s .

Also, did you try installing locally first @johnbarrett . We have a CommandBox installer: did you use the installer?

I don’t know why you’re posting that here again. Look above and read the comment thread. I’ve already

  • copied the relevant parts of the error into your original post
  • asked a followup question about it

Focus on answering the questions I’ve already asked.

I used the installer on the site of Hostek. Let me try to install it locally now.

When you use phrases like “the installer”, you may know what you mean, but we have no earthly clue :slight_smile: We don’t work for Hostek and I’ve never personally used their services. That’s like telling me you tried fixing your car with “the tool” from the garage. yeah-- I’ve no clue what that means :slight_smile: You need to be much, much more specific about whatever it is Hostek is doing.

Also, still waiting for your reply to my question about your Java version above.

I am so sorry. Hostek, the hosting company has an installer that you can use to install conentBox. It is one of their installers, just like they have an installer for WordPress. I am going to try to upload the files from your installer. I am still waiting to hear back from the hosting provider about the java version

9 posts were split to a new topic: Errror running ContentBox Installer with MySQL 8 locally

Just dump it out! it’s available in the server scope. no need to ask them about it.

My recommendation is to forget hostek for a minute. Use our installer locally and see if it works. if so, you can take up a conversation with Hostek about what may be wrong with their installer. But we can’t support hostek’s installer here since we didn’t write it and we don’t know what it even is.

The version of Java is 11.0.19.

I formatted your stack trace above and placed it in a code block which is three backticks before and after-- just like Slack. This is easier to read AND automatically scrolls when it’s long to keep things tidy.

The java version on the remote host {Hostek} is Java 11.0.19.

@johnbarrett @lmajano I have split these two threads. This original thread is for the Hostek errors. The primary question is whether ContentBox CMS is tested and works on Adobe ColdFusion 2021 and Java 11.

module java.base does not "exports jdk.internal.loader" to unnamed module

It is. We have this all automated in github actions, ohh spoke too soon. I see that acf2021 is not running the automated tests. I will have to add them and verify.

I’ve heard from two people today who said Hostek explicitly told them they couldn’t use Contentbox on Adobe-- only Lucee. We may want to follow up with Hostek and see why they’re telling people this and if we can help them update their information.