Errror running ContentBox Installer with MySQL 8 locally

I tried to use your installer (ContentBox Modular CMS), but I get the error:

Error in executing the DDL.

Specified key was too long; max key length is 1000 bytesOther Errors :

  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement
  • Error executing DDL via JDBC Statement


  • Check the ColdFusion documentation to verify that you are using the correct syntax.
  • Search the Knowledge Base to find a solution to your problem.
    Browser Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15

Remote Address
Date/Time 17-Feb-22 08:58 PM

Stack Trace

org.hibernate.tool.schema.spi.CommandAcceptanceException: Error executing DDL via JDBC Statement 
at org.hibernate.tool.schema.internal.exec.GenerationTargetToDatabase.accept( 
at org.hibernate.tool.schema.internal.AbstractSchemaMigrator.applySqlString( 
at org.hibernate.tool.schema.internal.AbstractSchemaMigrator.applySqlStrings( 
at org.hibernate.tool.schema.internal.AbstractSchemaMigrator.applyIndexes( 
at org.hibernate.tool.schema.internal.GroupedSchemaMigratorImpl.performTablesMigration( 
at org.hibernate.tool.schema.internal.AbstractSchemaMigrator.performMigration( 
at org.hibernate.tool.schema.internal.AbstractSchemaMigrator.doMigration( 
at org.hibernate.tool.hbm2ddl.SchemaUpdate.execute( 
at org.hibernate.tool.hbm2ddl.SchemaUpdate.execute( 
at coldfusion.orm.hibernate.HibernateConfiguration.exportSchema( 
at coldfusion.orm.hibernate.HibernateConfiguration.exportSchema( 
at coldfusion.orm.hibernate.HibernateProvider.initializeORMForApplication( 
at coldfusion.orm.hibernate.HibernateProvider.beforeApplicationStart( 
at coldfusion.filter.ApplicationFilter.fireBeforeAppStartEvent( 
at coldfusion.filter.ApplicationFilter.invoke( 
at coldfusion.filter.RequestMonitorFilter.invoke( 
at coldfusion.filter.MonitoringFilter.invoke( 
at coldfusion.filter.PathFilter.invoke( 
at coldfusion.filter.IpFilter.invoke( 
at coldfusion.filter.LicenseFilter.invoke( 
at coldfusion.filter.ExceptionFilter.invoke( 
at coldfusion.filter.ClientScopePersistenceFilter.invoke( 
at coldfusion.filter.BrowserFilter.invoke( 
at coldfusion.filter.NoCacheFilter.invoke( 
at coldfusion.filter.GlobalsFilter.invoke( 
at coldfusion.filter.DatasourceFilter.invoke( 
at coldfusion.filter.CachingFilter.invoke( 
at coldfusion.CfmServlet.service( 
at coldfusion.bootstrap.BootstrapServlet.service( 
at io.undertow.servlet.handlers.ServletHandler.handleRequest( 
at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter( 
at coldfusion.monitor.event.MonitoringServletFilter.doFilter( 
at coldfusion.bootstrap.BootstrapFilter.doFilter( 
at io.undertow.servlet.core.ManagedFilter.doFilter( 
at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter( 
at org.cfmlprojects.regexpathinfofilter.RegexPathInfoFilter.doFilter( 
at io.undertow.servlet.core.ManagedFilter.doFilter( 
at io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter( 
at io.undertow.servlet.handlers.FilterHandler.handleRequest( 
at io.undertow.servlet.handlers.ServletChain$1.handleRequest( 
at io.undertow.servlet.handlers.ServletDispatchingHandler.handleRequest( 
at io.undertow.servlet.handlers.RedirectDirHandler.handleRequest( 
at io.undertow.server.handlers.PredicateHandler.handleRequest( 
at io.undertow.server.handlers.PredicateHandler.handleRequest( 
at runwar.Server$1.handleRequest( 
at io.undertow.servlet.handlers.SendErrorPageHandler.handleRequest( 
at io.undertow.server.handlers.PredicateHandler.handleRequest( 
at io.undertow.servlet.handlers.ServletInitialHandler.handleFirstRequest( 
at io.undertow.servlet.handlers.ServletInitialHandler.access$100( 
at io.undertow.servlet.handlers.ServletInitialHandler$ 
at io.undertow.servlet.handlers.ServletInitialHandler$ 
at io.undertow.servlet.core.ServletRequestContextThreadSetupAction$ 
at io.undertow.servlet.core.ContextClassLoaderSetupAction$ 
at io.undertow.servlet.handlers.ServletInitialHandler.dispatchRequest( 
at io.undertow.servlet.handlers.ServletInitialHandler.access$000( 
at io.undertow.servlet.handlers.ServletInitialHandler$1.handleRequest( 
at io.undertow.server.Connectors.executeRootHandler( 
at io.undertow.server.HttpServerExchange$ 
at org.jboss.threads.EnhancedQueueExecutor.safeRun( 
at org.jboss.threads.EnhancedQueueExecutor$ThreadBody.doRunTask( 
at org.jboss.threads.EnhancedQueueExecutor$ 
at org.xnio.XnioWorker$WorkerThreadFactory$1$ 
at java.base/ Caused by: java.sql.SQLSyntaxErrorException: Specified key was too long; max key length is 1000 bytes 
at com.mysql.cj.jdbc.exceptions.SQLError.createSQLException( 
at com.mysql.cj.jdbc.exceptions.SQLExceptionsMapping.translateException( 
at com.mysql.cj.jdbc.StatementImpl.executeInternal( 
at com.mysql.cj.jdbc.StatementImpl.execute( 
at coldfusion.server.j2ee.sql.JRunStatement.execute( 
at org.hibernate.tool.schema.internal.exec.GenerationTargetToDatabase.accept( … 71 more

My java version is java 17.0.1 2021-10-19 LTS

You forgot to tell us what DB you are using.

I am sorry I am using MySQL 8

That going to be a serious problem. Adobe CF and Lucee don’t even run on java 17. I have a feeling java 17 is not what CommandBox is actually using. You can’t simply open a terminal and type

java -version

and expect whatever shows up there to be the version of java any particular app on your PC is also using. but to be clear, I don’t really care what you’re using locally. Not yet anyway. I asked what version of java you had on hostek only because the error message seemed to indicate that may be an issue.

johnbarrett@Johns-MBP ~ % java -version
java version “17.0.1” 2021-10-19 LTS
Java™ SE Runtime Environment (build 17.0.1+12-LTS-39)
Java HotSpot™ 64-Bit Server VM (build 17.0.1+12-LTS-39, mixed mode, sharing)
johnbarrett@Johns-MBP ~ %

Here is the error you need to be focusing on for your local install. This is an error coming right from MySQL and @lmajano would need to comment if he’s seen it or not. You can google it for what it means.

Did you read what I said above?? I literally said you can’t do that and get a useful answer! I’m not clear why you would go do it again. If you want to get the Java home in use by a given CommandBox server, run

CommandBox>  server info property=javaHome

But AGAIN, this really doesn’t matter and I never asked what your Java version was on your local PC because the error you had there was unrelated.

when I run the command in box, I get that I am using java 11.0.12

@johnbarrett @lmajano This newly split thread is for setting up ContentBox CMS locally with MySQL 8 and the DDL error you’re getting.

Specified key was too long; max key length is 1000 bytes

Is this something that I can fix in one of the files?

Not sure what you mean. A DDL error means an error in the SQL being run on the DB. ContentBox uses Hibernate, which means all SQL is generated on-the-fly by Hibernate and then run on the DB. So if there’s an error i the SQL, it’s not like you can just to edit that SQL somewhere in a .cfm file.

I’d wait and see if Luis has run into this. Based on a quick Google of the error message, it appears to happen when you have too many columns in an index. So I’m guessing one of the tables contenbox uses declares an index which has enough columns that it is causing this error on certain versions of MySQL.

Yes we have seen this issue before, but usually the default for MySQL 8 is 3072 bytes. So I am confused since I test on MySQL 8 and do not get this error.

@lmajano Can you share the name of the setting in MySQL in question? Then we can determine of @johnbarrett has adjusted his default configuration of MySQL to one that is invalid.

@johnbarrett I don’t see which CFML Engine you chose?

I am using ColdFusion 2021

Ok, I see that all of our automated tests are not running for ACF2021. So I will test manually locally as well and report back. I will also activate them in github actions.

thanks so very much for all your help. I really appreciate it very much

You got it! I am also tagging @Abilio how will be doing manual setup tests as well.

Ok @johnbarrett I have activated automated setup and testing for ACF2021 and everything is passing and building. You can see it here:

So this leads me to the path that maybe the contentbox-installer has an issue with MySQL 8 + ACF2021. That’s my next target. We will report back soon.