GetBean Method Not Found

Hi Phil, first of all, thanks for the help. The code you posted set me down the right path but it ended up a little different than what you have below. Also, because I am still learning I have not been able to get this method to work with all of my beans. My injectors looks like this:

This works wonderfully for anything in my handler and has stopped the errors referencing these beans. However I have a few beans that are more of a utility function that I call from the view itself. Stuff like encrypt a UUID or format a string. I tried changing the scope on the cfproperty to prc and a few other things but could not get it working. So right now I still call these the old way in my default prehandler and I still get the same errors on those functions. Here is an example:
prc.Crypt = getPlugin(‘ioc’).getBean(‘Crypt’);


prc.cms = cmsService.getContent(maxrows=9,);

<cfoutput query="prc.cms>

  • #Name#
  • I also tried calling the bean directly in the view but still got errors on that. Thanks again for all the help.

    Bill Munsell