Glassfish, railo and coldbox - messed up links?

hello, i am new to coldfusion and coldbox (and programming). i tried
to setup coldbox but some of the links in the sample applications are

My configuration is a glassfish v3 installation with the current railo
oss. i access my site through apache (2.2.14).

so instead of i access my environment
trough http://railo/

In railo i have a webroot mapping / to C:/webapps/myproject/.

i have copied the current coldbox 3M4 to C:/webapps/myproject/coldbox
- i can access the dashboard through http://railo/coldbox/dashboard/index.cfm
and have access to all options.

my problems start the moment i try to open the sample gallery:

I was testing Railo on Glassfish a few days ago and found the same thing.

No matter what I did I could not get the default document to work on Railo.

OpenBd stable/nightly and CF9 all worked right out of the .war deploy, but no matter what settings I tried I could not get Railo to use index.cfm as the default.

The new admin panel for Glassfish is top notch, hopefully this is just a config issue since Glassfish is so easy to install and use.

Just installed Tomcat - same problem

Yes, the problem lies on the servlet container itself. As the samples
uses SES URLs based on the front controller: index.cfm/

Some servlet containers support a mapping of: *.cfm/*
However, tomcat and others DO NOT. You can therefore either use a
full URL rewrite tool like mod_rewrite on apache, a rewrite filter for
j2ee servlets or add the mapping of index.cfm/* to your web.xml

This problem is only seen on servlet conainters like tomcat, jetty,
and I believe glassfish.