How is this done in wirebox, attempt number 3 to get this working

Since moving over the configuration to use wirebox instead of using the IOC method, I have had nothing but troubles that I am asking for help on. Unfortunately all 3 attempts have gone unanswered.

So here it is again, when using wirebox I have to change

property name=“pageService” inject=“IOC:pageService@pages”;

Now I can’t see what this needs to be changed too, I have tried module, model and numerous others. No matter what I have tried this is never wired in by wirebox, so the question is what do I do here for modules.

Regards,

Andrew Scott

http://www.andyscott.id.au/

You have to change to “model:pageService@pages” or “id:pageService@pages”

However, YOU NEED to create the mapping for it in your module config.

binder.map(“pageService@pages”).to("#modelMapping#.model.PageService");

Luis F. Majano
President
Ortus Solutions, Corp

ColdBox Platform: http://www.coldbox.org
Linked In: http://www.linkedin.com/pub/3/731/483
Blog: http://www.luismajano.com
IECFUG Manager: http://www.iecfug.com

Is there any reason why I have to do this manually? Why would/should I do this for Module Conventions?

Can’t ColdBox and WireBox together work this out, especially for dynamically adding paths like using appendExternalLocation() for instance.

I guess until this stuff is sorted out, WireBox is not an option for my Application, as I rely on the niceness of not having to do anything more than what I have done with IOC and it just works. WireBox inside of ColdBox I would have thought that this would work the same, without having to add extra mappings for all the dynamically created directories and module conventions.

Sorry I just see the added mapping you say I need to do is one step more than I should have to do.

Now if I am using WireBox as the framework, and that is actually WireBox running as an IOC but is still WireBox makes me wonder whether I really need to do the full blown WireBox config then either, or just use WireBox running as an IOC.

Regards,

Andrew Scott

http://www.andyscott.id.au/

Ok so after removing the @ I can now get it to work, I am going to take it that the @ is not known in WireBox like it is in IOC uses.

Regards,

Andrew Scott

http://www.andyscott.id.au/

Ok so after removing the @ I can now get it to work, I am going to take it that the @ is not known in WireBox like it is in IOC uses.

Regards,

Andrew Scott

http://www.andyscott.id.au/