Possible bug with ColdFusion 11 and ORM

Can anyone confirm this please, I have looked over this and can’t see why this doesn’t work.


select new map(parent.Id as forumId, parent.name as name)
from fbCat node, fbCat parent
where node.left BETWEEN parent.left AND parent.right AND node.forumId =:forumId
order by node.left

When I dump this I get a struct, that actually has the correct information within the struct. I would assume that I could do this


There is an error that says name doesn’t exist, yet in the dump it is clearly there. I am assuming this has something to do with it being an actual Java Object. So with that, how would I return the name in this method?

Reference : http://www.aliaspooryorik.com/blog/index.cfm/e/posts.details/post/hql-tip-use-a-hashmap-283

The problem is the case sensitivity of the map returned. The map is a native Java object so case sensitive applies

Luis Majano
Ortus Solutions, Corp
P/F: 1-888-557-8057
Direct: (909) 248-3408

ColdBox Platform: http://www.coldbox.org

ContentBox Platform: http://www.gocontentbox.org
Linked In: http://www.linkedin.com/pub/3/731/483

Social: twitter.com/ortussolutions | twitter.com/coldbox | twitter.com/lmajano | twitter.com/gocontentbox

I thought the same thing, but when I tried


I also got the same error, at least that’s what I thought. Since going back to this it seems to work again. I am guessing some weird caching happened.