Problem with ColdBox Utilities Platform

Hi Guys,

Anyone have the same problem when creating a new module from ColdBox
platform in CF Builder 2:

There was problem creating the module: An exception occurred when
performing a file operation moving a file to another filesystem on
files E:/www/development/matchinggame/modules/Access/handlers/
HomeScript.cfc and E:/www/development/matchinggame/modules/Access/
handlers/Home.cfc. The cause of this exception was: E:\www\development\matchinggame\modules
\Access\handlers\Home.cfc (Access is denied).

Any idea's?


The only thing that I can suggest here is to check your file permissions, have you tried running a file in the browser from this location to see if CF can access those directories?

Yes, it can access it, it is my webroot and the app is generated by coldbox platform. I even tried giving everyone full access, but i get the same error.

It is even more strange... It creates part of the module:

modules (modules folder in my app)
- Access (name of module)
-- handlers
--- HomeScript.cfc
-- views
--- home
---- index.cfm
-- ModuleConfig.cfc
-- ModuleConfigScript.cfc

The generated ModuleConfig and ModuleConfigScript files are not
parsed.... Meaning they show up like this:

  // Module Properties
  this.title = "@title@"; = "@author@";
  this.webURL = "@authorURL@";
  this.description = "@description@";
  this.version = "@version@";

So @title@ etc... never gets replaced by my module name...

So if it was a permission problem, why is it able to create the
handlers folder, but not the Home.cfc file?

I am guessing that the directory with the Extension has a permission problem, have you tried running CFB2 as an administrator? It should always when running pop up a warning when starting if it is running as an administrator.

Yep, ran it as administrator in two ways: 1 by rightclicking and
choosing run as administrator and 2 changed the properties of the
start-up icon to run as administrator (compatibility tab).

Some extra info: running coldbox platform utilities 2.7.

Just experimented... If I don't check the box for Script Based CFC,
then I don't get that error...?

Could it be a bug?

What version of ColdFusion?

Adobe ColdFusion 9.0.1

And all of the other ColdBox platform wizards work ok when i check
Script Based CFC.

Might have to wait until Luis jumps in.