RE: [coldbox:14719] Error updagading to 3.5

Is there a CFC named setupVariables.cfc in the root of the models folder? I think that’s the only way that would work since you don’t have any other mappings or scan locations in your WireBox binder config.

If not, where is the file located in your directory structure?



SetupVaribales is locates of the root of the model folder. And then I have a mapping routine

cfdirectory action=“list” recurse=“true” type=“file” directory="#ModelDirectory#" name=“modelFiles” listinfo=“name” filter="*.cfc" sort=“asc” >

<cfset aliasName = ReplaceNoCase(listLast(name,’/’),’.cfc’,’’) >
<cfset aliasPath = ReReplace(name,’.cfc|/’,’.’,‘all’)>
<cfset aliasPath = ReReplace(aliasPath,’.$’,’’)>

<cfset addModelMapping(alias="#aliasName#",path="#aliasPath#") >


I had experienced similar issues while upgrading to Coldbox 3.5. Got solved by installing Coldfusion 9.0.1. You need Coldfusion 9.0.1 and not just 9.


How does WireBox binder config. should look like

I am running on

I did the update one more time and it still throwing the same error

And you removed the Autowire from the interceptors in Coldbox.cfc?

When You say remove just commented out this 3 line in config file


Yes, I have mentioned it many times now. It is no longer part of Coldbox as of 3.1+ did you not read those messages?

I did and it is commented out. But still get the same error message

Which is thr DSL message? And that is because it can’t find the setupVariables, so Brad asked you a question is that the name of the CFC, and did you try my other suggestion with the DI property?

I think I heard you say it is in the model directory, but you didn’t say if the name was identical and you made no attempt to come back with what I suggested with the DI.

Secondly on top of all this, did you read the notes / docs on upgrading to Coldbox 3.5 to see if there is something in there that you are still doing that needs changing?

This is assuming that the error message is still the DSL error!!

The name of the cfc is the same. I did read the docs for upgade unless I was reading the wrong doc. But there was not much. Would you mund posting the link to that document . Thank you

And what about the other suggestions we have given you?

Did you setup the log appender as suggested, so you can see more information on the problem? You will be surprised what info you will find in there when setting it up to log errors and other info.


And what is in the log files?

The logBox does not semms to work. What steps that need to be made to make it work

hmm, you said you had tried it!!

Secondly can you confirm that you made the property changes for the DSL, and that you reinited the application or restarted ColdFusion?

I do not know if it let me reinitialize I put fwreinit and I also restarted coldfsuion server multiple times

Because i do not event get coldbox debugger at the buttom of the page

Ok show me the current error message.