RE: [coldbox:17608] [Coldbox-3.5.3] Model not showing up as expected when injected into plugin

Hmm, I noticed you alternated back and forth between calling it “userservice” and “userservices”. Is there a chance that is the issue. Dump out your variables scope and see what’s in there.

If that doesn’t work, try enabling debug logging for coldbox.system.ioc to get more info on whether or not the injection is taking place.



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

You know, that kind of interchangability is really working against me.

But, I tried what Andrew suggested and as you just suggested, it made not difference (and did not conform with what I was readying in the documentation). The “UserServices” variable is the mapped reference and “userservice” is the property name and I double checked the code and that is correct.

try this

property name=“UserServices” inject=“id:UserServices”;

And change your other code to use the new property name, I think they need to be the same name as well.

Andrew Scott

well that does not make any sense really, I should be able to name my property whatever I want…however, good suggestion because after fwreinit, I get the same error message and there is no longer ANY variable named “userservice”…everything as you suggested is now called “UserServices”…which means something else has gotten hung up somewhere.

And lo and behold, I restarted CF and Apache (just for the hell of it) and I move past the error…it’s pretty frustrating when the server is your problem the whole time…now I have to go back and figure out which is the best syntax for the injection is or if that’s what caused the hang up in the first place. Groan.

But thanks for the pointers and direction guys, they really got me out of a bind.



I made this very clear on a number of posts to you personally, so you need to take the following on board as part of your debugging process.

Reinit the framework, if you find it is still happening then you need to then change the Application name and try again, there is no need to restart ColdFusion when you change the Application name.

I don’t know if this is a caching issue, or something else, but I have run into this problem more often than not, that re-init the framework sometimes doesn’t work the way you expect it too.

Andrew Scott