The target requesting the dependency is: 'moduleService@cb'

Has anyone seen this error before with ContentBox 2.0. The site is on Hostek. This was reported as a bug. Any clue as to how I might get the site backup?

Tried reiniting the fw with no positive results.
The DSL Definition {REF={null}, REQUIRED={true}, ARGNAME={}, DSL={model}, JAVACAST={null}, NAME={modulesInvocationPath}, VALUE={null}, SCOPE={variables}} did not produce any resulting dependency

The target requesting the dependency is: ‘moduleService@cb’

The Error Occurred in
/coldbox/system/core/util/Util.cfc: line 164

Since you can’t restart the server, can you try changing the application name in your Application.cfc? This should force a reinit. Also, you may be able to call applicationStop() in your Application.cfc’s onRequestStart() method to restart the app.

What preceded the error? Were you performing an upgrade, or did it just appear?



ColdBox Platform Evangelist
Ortus Solutions, Corp

ColdBox Platform:

Brad that worked by changing the of the Application.cfc. What I was doing was removing some modules. I did an fwreinit and it causes this. When I tried to dump
<cfdump var="#getController().getWirebox().getBinder().getMapping(‘moduleService@cb’).getObjectMetadata()#> this I got this reported Railo error about application.cbBootStrap not existing.
The onSessionStart method somehow is starting before onApplicationStart has finished executing. Luis reported this as an error already for Railo 4.2.1.