Transfer-ORM Error

Hi Guys,
I'm trying to use Coldbox with Transfer-orm in a app under Railo 3.0
(Also tested in a CF9 Server).
But, CF9 and Railo 3, return a same error:

Application Execution Exception
Error Type: expression : 0
Error Messages: key [TRANSFER] doesn't exist in struct (keys:__HASH)

To check all possibilities I've updated Coldbox and Transfer-ORM with
yours SVN Servers, and... the error persists

I also try to use a Sample Application in Coldbox:

With the same error...
It's a bug?

Hi Christiano,

Could you share the code you are using to call Transfer?

How are you loading Transfer into your ColdBox application? Are you
using ColdSpring or anything? Just the dependency injection in
ColdBox? The Transfer loader?

I can help you here if you can answer these questions and post your
configuration / sample code.

Are you using ColdBox 3.0?


Hi Jim,

I just copy the sample "SimpleBlog" to learn more about Coldbox /
Using: Coldbox 3, Railo 3, Transfer 1.1

I'm out office now, if need I send my code, but the error is the same
with the Sample Code


I have to ask, but... do you have Transfer downloaded and a mapping
created for it?

Hi Jim,

yeap, downloaded and mapped :slight_smile:

It's working fine with Coldbox 2.6.4,