Undefined Variable Exception (Caching Bug)

My site is on a Windows server with CF8 and CB 2.6. Here is the
exception message:



Did you upgrade ColdBox without restarting Coldfusion?

Hmm... good question. I may have. This site is on a shared server so
getting CF restarted is not as easy as it should. A simple fwreinit
won't do the job, uh?

Nop...you need to restart CF

That was a bug in release candidate 2 on the LFU expiration policy. It was fixed for release. You might need to update your code.

If you can’t restart the server, you might want to create a clean.cfm template that deletes everything in application scope. However, that does not remove the compiled class files that CF will create from the code. That might need a server restart.


I was able to get the hosting company to restart the server and that
appears to have worked. Thanks for the detailed explanation Luis!

Unfortunately, I am having a similar problem with a model CFC I
created. It keeps throwing an error. I removed the code, reinited and
still I get the same error. I also changed the app name and reinited
but still get the error. I also deleted the CFC from the server
entirely, changed the app name, reinited, got cfc file doesn't exist
error, reuploaded the edited CFC, changed the app name, reinited, and
still got the same error.

Is CB caching the model CFCs into compiled class files?


No Aaron,

CB doesn’t go that route. It might be something else in that cf server.


I didn't think so. How weird. I add the variable, got the error,
removed the variable, but now I can't get rid of the old file with the

Things that make you go hmm...

Is it possible that trusted cache is on? Or the "save compiled classes" option?

Also... totally outside shot here: is this inside a query?

what specifically is the error?

Unfortunately my client is on a shared hosting env. so I don't know if
trusted cache is on, nor "save compiled classes."

Here is the error:
Application Execution Exception
Error Type: Expression : [N/A]
Error Messages: Variable GETMYPLUGIN is undefined.

LINE: 98
Template: D:\home\revivalseminars.org\wwwroot\model\cart

I mistakenly tried to access the CB function getMyPlugin() within the
model. After getting the error I removed the call to getMyPlugin and
refactored the code to remove the dependencies but the edits are not
being recognized.

The site is running on Windows, CF 8 and CB 2.6

Reinit the framework?