unit testing handlers with resource bundles -- getting path errors

  I can get handler testing set up fine until I add an i18n resource
bundle into my config file. config looks like:


in setup() in my test, i have:


But something in the guts of the app is attaching
"includes/main_en_US.properties" to wherever the test is being run
from and not to my app mapping. In other words, it's not relative to
the config location, which is what I'd have expected.

For example, if I run my test from the eclipse plugin, it's looking
for the properties file in mxunit\framework\includes\

If I run the test directly, i.e.
it looks for it at
not found.

Now... it works if I set the DefaultResourceBundle to be a hard path,
i.e. /ArgusPReview/includes/main, but I'd actually prefer to keep
things relative inside my config file if I can help it.

Any thoughts here?

thanks a lot.


good catch marc I have logged this as a bug. All other paths work
except this one. I will let you know when it's done

This is fixed on SVN marc.



thanks a lot, Luis!