What's the URL for contentbox Administrator

Has to be a stupid question, but What’s the URL for contentbox Administrator?

I have tried /admin
/Administrator
/administrator

amd I’ve looked around various pages here - http://contentbox.ortusbooks.com/content/using/administrators/index.html

and even Googled “What is the contentbox administrator url”

I can’t wait to see how stupid I am…

/cbadmin

Look in the ModuleConfig.cfc for the admin module to see the module’s entry point.

https://github.com/Ortus-Solutions/ContentBox/blob/development/modules/contentbox-admin/ModuleConfig.cfc#L18

Thanks!

~Brad

ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

Thanks Brad! That’s pretty cool about setting the entry point name.

Now I can’t get into the admin. Invalid credentials. Did reset password with email and link. Looked in db table to make sure username was correct. When I received password pasted to text editor to make sure no extra spaces.
Does not work no matter how many times I try.

How can I reset password or add a new user? Do I have to reinstall all over again?

Okay, I reinstalled everything using commandbox, Lucee 4.5, contentbox-be

Went through the setup screens and used just my first name all lowercase for both username and password.
Got to last screen, clicked “visit administrator”, and still can’t login with username and password I just created.

I didn’t try non-bleeding edge yet but I’d love to know if someone can try it and see if they can login after install.

Also, I use mysql 5.7 although I don’t see what that would have to do with anything,

Sorry, don’t want to confuse anyone. I meant it would be great if someone could try BLEEDING edge and see if they have that problem.

Okay, I now installed a contentbox site using stable contentbox, NOT bleeding edge. New datasource, etc, Went through setup and still can’t login to admin.

Something bizarre going on here. I use linux and mysql 5.7

Hmm

Not sure risto. We have many sites setup this way. Not sure why you would get this.

Quick question. Are you using full rewrites?

Luis Majano
CEO
Ortus Solutions, Corp
www.ortussolutions.com
P/F: 1-888-557-8057

Hi Luis,

I just used commandbox multi-server and started server with server start --rewritesEnable (which as you know spins up Lucee 4.5 by default)

I will just have to try some other setups. I’m going to try using mysql 5.6 for the heck of it.

Let me ask you this, is there a way to have a blank password? Like a manual db update - “set password = ‘’” scenario

thanks

BTW, I do remember in the setup screens “What type of URL rewrites” I think I did leave it “coldbox express”. What should I choose a different one based on starting up the server the way I did?

Just curios. It shouldn’t affect login though.

Can you check how the tables got created and if your data is there.

Luis Majano
CEO
Ortus Solutions, Corp
www.ortussolutions.com
P/F: 1-888-557-8057

Hi Luis,

In cb_author I see my info with encrypted password

Hi Risto.

I went through several installs, on pc and mac, and did not run into this issue.

Before I continue, please REMOVE ALL COOKIES for the site.
I have seen some bizarre cookie issues mess me up in the past.
Try that first… if that doesn’t work, then I’ll ask more questions.

So to try and replicate this, can you give me a few more details.

1 - Where did you get the install? ContentBox Modular CMS
Did you use Source, War, or Express?

2 - What engine - I know you said you use commandbox lucee 4.5 one time, was it the same on other attempts, if so, with what?
I have been using Source with Commandbox.

3 - Since you have MySql 5.7 (and I have 5.5) maybe try installing with the embedded database H2.
Take MySql out of the equation.

4 - What flavor of linux are you using?

Hi Gavin,

I was under the weather and haven’t been in fromt of a computer in a couple days. Really appreciate you
trying to help me figure this out.

I will try some of your suggestions and get back ASAP.

I use Debian Linux and got the install by simple just doing “box install contentbox-be” and in the post above I mention I also tried
a fresh site with just “box install contentbox”. Neither work for me. I use the multi-server version of commandbox.

Thanks

Okay, this is driving me crazy.

Steps I just did:

  1. Cleared all cookie data from Firefox
  2. created a new folder called h2test and “box install contentbox”
  3. server start --rewritesEnable
  4. opened lucee 4.5 admin and created a new h2 embedded database named “h2test” username “sa” password blank.
    5 went through contentbox install screens - used “h2test” for user and password.
  5. Everything seems fine and I go to /cbadmin and type in “h2test” for both username and password and nothing

When I enter the credential no message. I’m just at /cbadmin/security/login with the previos user/pass blanked out with cursor
in username field with red border around it.

Same experience as the mysql tries. It’s crazy because everything looks good with frontend and administrator. Just can’t login

The only weirdness I have seen is when I first went through contentbox setup screens I checked no to database setup. I got the database screen filled out all the info. I did not work because it said my coldfusion administrator password was incorrect. I tried a few more times and still didn’t like it.

So I went to /lucee/admin/server.cfm and used the same password that contentbox didn’t like and got in to Lucee admin no problem?

Makes me think contentbox is somehow trying to use a different engine or something? I don’t know.

Risto I would be willing to do a screen share with you but after our conference next week. Is this possible

Luis Majano
CEO
Ortus Solutions, Corp
www.ortussolutions.com
P/F: 1-888-557-8057

Yes, that would be great. Just let me know a time that works for you.