500 error when importing one ContentBox site to another

Hello all, I want to export one CB site from a subdomain to a new site on another subdomain, for testing and development. The export went well. At first I was getting errors on the import into the new site because the import file was too big. I upped the file size limit in IIS and CF, and now the import appears to go along okay – it ticks up to 100% and then the page goes to refresh, and I get a generic 500 error every time. The IIS logs also give a generic 500 error (no subcodes).

I know this is kindof vague but I don’t have much else to go on. Any suggestions?

It is ACF 2016 on IIS, Windows Server 2012, and whatever the latest version of ContentBox is (just downloaded it today).

Thanks! I am happy to provide other info if you think it might be helpful.

Randy, while I don’t have specific Contentbox experience about such an odd 500 error, I have seen it more generically with CF (and IIS, especially) and can offer a couple of thoughts/suggestions that may help.

Your answer may be in the first one, or it may be the last (or none). Rather than ask one by one I’ll just offer all 3 here. Perhaps they may help others even beyond your challenge.

  1. First, have you check the CF logs to see if they track any error? Look especially at the application.log, then the coldfusion-out.log, coldfusion-error.log, or exception.log. The answer may be there. If it is not…

  2. Next, have you tried making the request ON the server, meaning in a browser that’s on the same machine as IIS? I ask this because by default the IIS “error pages” feature is set to show more detail if you make a request ON the server than if you make it from OFF the server. It seems perhaps too simple to be useful, but I help people leverage that about once a week.

  3. Finally, with regard to the “new site”, are you referring to a new CB site or (also) a new IIS site? If it was a new IIS site, are you confirming whether you would be able to visit ANY CF page in that new site? The reason I ask that is that this could be a generic problem of not being able to run ANY CF page in the new site, until you take an extra step. This too trips people up quite often.

If you or someone else had told the CF2016 installer to connect CF to “all sites” in IIS, or had used the CF “web server configuration tool” (wsconfig.exe) to configure “all sites”, a problem is that that no longer really means “all sites now in the future”, like it did for CF9 and earlier.

Instead, when you add any new sites going forward, you must ALSO create for that site a Jakarta virtual directory. If you look at the “isapi filters” feature for the new site, you should see it has a “Tomcat” handler pointing to a dll in a specific folder. Take that same path, and create a “new virtual directory” in IIS for that site, called “Jakarta” and pointing to that same DLL. You don’t need to restart IIS or CF. Just retry your CF page.

Let us know if any or none of those help.


Hello Charlie, thanks a lot! I am sorry, I should have mentioned earlier, the new site itself works fine. I can browse the site as well as cbadmin, although I have avoided making any changes there – the import was the first step I have tried.

But to reply to your suggestions, I did try the import on the server itself, with the import file being stored there on the server, but that did not help. I did not see anything in the CF logs either, but I am currently running an import right now to make sure I have the latest entries (if any).

I wonder if this is what I need to be doing at all, though. I wonder what would happen if I just flew over the contents of the old database into the new one? We do have some customization in our theme, but very little.

BTW, I know that Ortus cautions us against running ContentBox under CF 2018, but the public-facing part actually works very well. Better than under CF 2016, in fact, where every 2-3 days the site crashes hard with an ORM error about the datasource not being properly configured or something. This goes away with a server restart, but it does happen every 2-3 days. The cbadmin also works pretty well under CF 2018, although sometimes creating new entries or editing existing ones triggers an error.


Okay the import just gave me the same error. In coldfusion-error.log I see this entry followed by a bunch of other gobbledygook. (Well it is gobbledygook to me haha). I did not see anything specifically identifying ContentBox, but the timing is right on. The import file is about 1.2 GB in size, and this is not the only site running on our CF 2016 server, which has 12 GB of ram.

Could this be the problem? I will try the Mister Picky option to see if a smaller file gets imported.

So I tried Mister Picky to export everything from the old site except our media store, and I got a much smaller file. Unfortunately, when I try to import that into the new site, I get

Which it is the right file, so back to the drawing board, I guess.

Well, here again I have no experience with the CB import mechanism–and I had never head or “mister picky” before reading your notes. :slight_smile:

But as for your memory error below, we may be able to solve that. The question then is whether that might fail for the same reason as this next import, but it seems worth a shot.

As for the memory error, that’s about file upload settings in the cf admin “settings” page. What are your values for
“Request Throttle Memory” and “Maximum Size of Post Data”? If the former is less than the latter, raise it to be equal to or larger than the latter. Try it again (perhaps with a CF restart to be safe), and let us know how it goes.


Thanks Charlie, I made those settings in the CF Admin. I would like to try them out, but now I am getting the dreaded “” error, which seems to pop up every few days until I restart the server. ContentBox seems like a good piece of software, and I do not know if it is my hosting setup (VPS with Hostek) or what, but I have plenty of problems with it.

Quick follow-up – restarted the server and that cleared the ORM error. It also cleared the evident file size problem, because I am no longer seeing that in the logs. Now I am just getting:

Sorry, the imported ContentBox package was not valid. Please verify you have the right file and try again.

Which is what I got for smaller files too, so evidently file size was a problem, but not the only problem. But hey, it is progress of a sort…

While we await in hope of others to help (with more specific Contentbox or ORM experience), can you clarify what settings you had and changed (of the ones I mentioned)? It could help others if they find this in the future.



Sure thing, in the CF 2016 admin under Server Settings > Settings, I had previously changed “Maximum Size of Post Data” to 1500 MB. That change by itself did not clear the original error I was getting, so on your advice I then changed “Maximum Size of Post Data” to 1800 MB and also changed “Request Throttle Memory” to 2000 MB. That did indeed clear the file size error. Thanks! Now all I get is the invalid file type error. :slight_smile:

BTW, on the brand-new test site, I did an export of everything from it, and then tried to import it back into the same site. I still got the invalid file error.

Thanks for the update. I am hoping now someone especially with experience in Contentbox export/import process will chime in.