AJP configuration

Hello,
i have a server with Lucee (installed) 4.5.1 >> BONCODE >> IIS, yesterday i migrated to Lucee 5.2.8 with Commandbox >> BONCODE >> IIS
but on IIS log I found some 502 errors.

The client for some request see 502 Bad Gateway.

BONCODE settings are the same in both configuration, I think the issue is a timeout or packet size(the http request send me some Kb of XML).

In server.xml of Lucee installed i have:

Is it possible to modify “packetSize” and “connectionTimeout” on Commandbox?

Best regards,
Emanuele

In my experience 502 errors are not about those attributes, but rather some other issue, and worse are really tough to troubleshoot due to lack of logging. Are you sure the service is running and listening to that port?

Hello,
yes, service run correctly.
Many page response correctly status 200.

On boncode log I found:

2019-01-29 15:47:45 1.0.37 ERROR
TCP Client level – Server/Port:localhost/8052
Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
at BonCodeAJP13.BonCodeAJP13PacketCollection.get_Item(Int32 index)
at BonCodeAJP13.BonCodeAJP13ServerConnection.ComunicateWithTomcat()
at BonCodeAJP13.BonCodeAJP13ServerConnection.HandleConnection()
at BonCodeAJP13.BonCodeAJP13ServerConnection.p_CreateConnection(BonCodeAJP13PacketCollection packetsToSend)
2019-01-29 15:49:28 New Connection 7 of 0 to tomcat: 127.0.0.1:8052 ID: 7 [T-58]

Thank you

In my experience 502 errors are not about those attributes, but rather some other issue, and worse are really tough to troubleshoot due to lack of logging. Are you sure the service is running and listening to that port?

All of those settings aren’t currently tunable, but we have a ticket in for it. Feel free to comment there:

https://github.com/cfmlprojects/runwar/issues/133

As to your error, I doubt it is related to those settings. Can you confirm that you are on the latest version of BonCode. That issue may have been fixed. The latest BonCode is 1.0.41 and you can confirm what version you have by appending ?BonCodeConnectorVersion=true to the end of a URL when hitting IIS LOCALLY.

Hi Brad,


All of those settings aren’t currently tunable, but we have a ticket in for it. Feel free to comment there:

https://github.com/cfmlprojects/runwar/issues/133

Done :slight_smile:


As to your error, I doubt it is related to those settings. Can you confirm that you are on the latest version of BonCode. That issue may have been fixed. The latest BonCode is 1.0.41 and you can confirm what version you have by appending ?BonCodeConnectorVersion=true to the end of a URL when hitting IIS LOCALLY.

I upgraded BonCode now to the last version, I will check the logs.

The strange is that on installed Lucee I use a older version but i don’t see any error.

Bye