Baseurl = on home page, fresh install

Hello All,

I installed contentbox tonight for the first time using commandbox.

I can login to the admin area and it is fine, looks nice.

The front side of the website loads but there are no styles.

I found that the reason is because the baseURL line is set to this:

<base href="" />

even though I am accessing the site using a domain name.

I have nginx proxying to commandbox.

Any idea how I can get the baseURL to show my domain name?



You will need to configure NGINX to send the host headers so that they can be picked up.

        proxy_set_header Host               $host;
        proxy_set_header X-Real-IP          $remote_addr;
        proxy_set_header X-Forwarded-For    $proxy_add_x_forwarded_for;

Thanks Jon, I will check that out today. That is typically part of my setup recipe but I must have skipped over it in my haste to give ContentBox a try.

Another thought is did you set the “Domain Base URL” in the site settings of the contentbox site? You can find site settings under System > Sites and then select the default or current site your working on.

Hi All,

The proxy settings were already in place. I tried what Mike suggested. My default site was set to I changed:

*Domain Expressions
*Domain Base URL:
Site Force SSL (Secure Sockets Layer):

and it now sets the domain properly.

Thanks for your help.

1 Like