Broken Install of coldbox-zero-to-hero videocast

I’m following the coldbox-zero-to-hero videocast and have had this working on several occasions.

I’m now going through it using coldfusion 2021 rather than lucee and have run into what I think is a bug - shown above. This happens after installing all the necessary packages in coldfusion (mysql and pdf).

Element to is undefined in ARGUMENTS. - I have no idea where to start on figuring this out but the problem does not exist in lucee. I almost get to the end of step04.
And the problem shows in the top level page - main/index and about. Tests still work but with the same error as shown above.

I changed the server to a lucee install and it works perfectly. On changing back using command box to CF2021 the same problem appeared.

I then tried CF2018 and CF2016 - Same problem

So there is a difference between CF and Lucee, but I really don’t know where to look. If anybody can point me in the right search direction I’m happy to spend time on this!

I need to use CF2021 at the moment so am a little scared that this bug/difference will cause other problems…

Hmm, Can you point out which version of ColdBox are you using and also which patch level are you on with Adobe?

Hi Luis

Sorry did not see a notification email about your reply!

CF Engine: adobe 2021.0.05+330109 (It’s also broken on the latest versions of 2018 and 2016…

“coldbox”:“^6.0.0” - What ever is the latest version of 6.0

I wonder if it would be better to use version 7? Bear in mind though it works with Lucee!

Thats what comes of being a newbie in ColdBox!



Hmmm, All Adobe 2018+ engines are fully supported on ColdBox. So I am perplexed your code is not working. Can you send me the offending code or how to reproduce it please.