Caching not installed error, when it appears it actually is


I’m working through the Adobe ColdFusion certification online course.
I am not new to ColdFusion, but am new to ColdBox.

We installed ColdBox and Derby.

One of their pages with a query is giving an error :

" The caching package is not installed.
You can install package through CLI package manager (C:/Users/lamar/.CommandBox/server/B539AB7670F70D2981CB7C380CB13C77-cf_specialist_exercices/Adobe-2021.0.13.330286/WEB-INF/cfusion/bin/cfpm.bat) by running the command : install caching."

The query is:
cfquery name=“qMovies” result=“rsltMovies” cachedwithin=“#createTimespan( 0, 0, 5, 0 )#”

I checked with listall and it says caching IS installed.
Query works fine if I take out the “cachedwithin”.
I tried installing it again (install caching) anyway and get this error:

"CommandBox:cf_specialist_exercices> install caching
× | Installing package [forgebox:caching]
| Verifying package ‘caching’ in forgebox, please wait…

Error getting ForgeBox entry [caching] The entry slug sent is invalid or does not exist

ERROR (5.9.1+00767)

Error getting ForgeBox entry [caching]

The entry slug sent is invalid or does not exist"

I have no idea how to fix this, have searched high and low.

Any help would be greatly appreciated!


That error is referring to the ACF caching package. That will need to be installed by CFPM. box cfpm install caching. The Adobe packages don’t reside on Forgebox ( where box install … looks for packages

Do you have any idea how to install what I need? A link perhaps?

Caching extension IS installed in my Adobe ColdFusion install.

I’m very new to ColdBox.

When I list installed packages on ColdBox “caching” is listed as installed.


Ok. I guess there’s no solution to fix this.

See the docs on the cfpm command in CommandBox:

You can’t install adobe coldfusion modules with the CommandBox install command, and now that you’ve attempted it you likely have a bogus caching entry in the dependencies array in your box.json file. You’ll want to remove that as well as install the caching module properly using cfpm install caching.

Once you have the ACF caching module installed, you should restart the server to ensure it is picked up.

Do you have a link that might explain what you’re suggesting?
As a total newbie, I have no idea how to do what you’re saying.

I don’t see a box.json file. Where is that located?

I DO see a “box.exe” and “server.json” file in root folder.

Below is what’s in that file.


  • Open the CommandBox CLI where you started the server (presumably)
  • cd into the web root of the server
  • type cfpm install caching
  • press enter
1 Like

AWESOME…!! That worked.

Thanks so very much. :smiling_face_with_three_hearts:

1 Like