CBWire 3 - Enable Turbo - Error in Browser Console


I’m new to CBwire and for the most part it’s working, until today I tried adding “EnableTurbo” : true to my Coldbox.cfc. I believe I’m using the latest version of CBWire.

cbwire : {
    "autoInjectAssets": true,
	"enableTurbo": true

I get an error in my Chrome browser console.


Any idea on how to resolve this error?

Hi, @West !

Call me crazy, but the full error message would be helpful here. :slight_smile: What does it look like when you click on the error in the console, to expand the error stack trace?

I’m wondering, if you try the manual installation method, do you have any more luck?

@MichaelBorn - There isn’t much showing at all. Here is a screenshot showing the expanded stack trace. I have not tried the manual installation, but I will later today as time allows and post back.

1 Like

@West There appears to be a recent issue reported with the unversioned Turbo link on Skypack, which is what CBWIRE defaults to using.

As a workaround, you can disable ‘enableTurbo’ and then manually add the references in your layout file.

cbwire : {
    "autoInjectAssets": true,
	"enableTurbo": false

In your layout file:

    <script type="module">
        import hotwiredTurbo from 'https://cdn.skypack.dev/@hotwired/turbo@7.3.0';

You can leave the setting ‘autoInjectAssets’ enabled.

Thanks! That resolved the error.