CFCasts Not Displaying Videos

I think there may be an issue with some of the new ColdBox 6 videos posted recently?

I pass this along internally and hopefully someone will follow up here. Thanks for pointing it out.

This should be resolved now. Thanks for the report.

Thank you folks – all sorted now.

1 Like

The problem still exists and displays " Sorry - Because of its privacy settings, this video cannot be played here."

I’ve discovered that some videos won’t stream if HTTP Referer is disabled or spoofed. I use uMatrix and have this globally disabled for the past 3-4 years. I haven’t encountered any issues watching videos on other video platforms. I’m a Vimeo Plus subscriber and embed videos on my client websites without issue. This header requirement is probably a security feature to prevent unwanted leeching & unauthorized embedded, but it can be problematic for privacy conscious users. This was the first video that I tried watching and it didn’t work. (New developers that aren’t familiar with Ortus or CFML may leave without reporting issues or returning.)

I didn’t report this back to an Ortus PR & Marketing specialist until 2/8.

@JMoberg According to Vimeo’s docs here, this is needed to restrict the video to certain domains. I would add an exception to this rule for CFCasts in your adblocker.

To be clear, James’ issue is different than the one reported by Richard. The video Richard linked to actually had an improper configuration in Vimeo and that has been resolved.

Due to the past existence of drive-by malware on popular sites, I use uMatrix on Firefox, Chrome, Edge & Brave. The HTTP Referer option is globally enabled or disabled. There is no per-site configuration for it like there many other options (cookie, css, image, media, script, XHR, frame, other).

I don’t use other privacy/security/anti-ad extensions, but I believe that sending referers is an option that exists for other products other than uMatrix. Again, I haven’t had to disable this feature to watch embedded media on any other website and I’ve been using this extension for more than 3-4 years.

We used the HTTP Referer to protect some downloads in the past, but had to disable it because it was negatively impacting Safari user.

I recognize we’re in the realm of anecdotes here, but the first video site I tried also had this issue.

  1. I download uMatrix.
  2. I visited Laravel From Scratch: At a Glance which is a free video on
  3. I allowed everything in uMatrix but kept the Referer header spoofed.
  4. I got the same error.

Other video providers may choose to implement this a different way, but we are choosing to use Vimeo and to use their domain protection. I’m sorry that this isn’t compatible with your adblocker of choice.