[CFConfig 1.0] [CommandBox 4.2] Cannot import customTagPaths to embedded server

Using commandbox and cfconfig I exported my adobe coldfusion 2016 settings with the intention of moving them to an adobe2016 server managed by coldbox. Everything seems to work great except for custom tag paths. According to the documentation it looks like this should work however nothing I’ve tried has been successful.

The customTagPaths property did not appear in the json generated when I exported from my server.
I attempted to set customTagPaths manually in my json and then import using cfconfig but it never makes it into my cfadmin settings.
Finally I did a cfconfig set [tab] [tab] to see the list of all setting options and “customTagPaths” (or anything like it) did not appear in the list of available settings.

Am I missing something or is this feature yet to be implemented?

Also, as a side question, I noticed that in the cfadmin for my commandbox server the “Java and JVM” settings are missing. Does the JVM argument in server.json fulfill the same roll as this tab in cfadmin?

Thanks for your help!

Can you make sure you’re on the latest cfconfig? I did some custom tag fixes just last week. Also, Adobe only shows the jvm page when deployed on Tomcat. Server.json is where you configure those items in CommandBox.

I am using version 1.0.3. I updated earlier this morning before attempting any of this.

I did a cfconfig set [tab] [tab] to see the list of all setting options and “customTagPaths” (or anything like it) did not appear in the list of available settings.

It turns out I was on an older version. It seems my update --system earlier in the day didn’t install the latest version for me. I did the list --system like you suggested, tried to update again, and then moved on to just installing. Installing seemed to work and I am now on version 1.0.3. Here is the output

`

list --system
Dependency Hierarchy for (1.0.0)
└─┬ commandbox-cfconfig (0.11.4-alpha)
└─┬ cfconfig-services (1.0.3)
├── lucee-password-util (1.0.3)
├── coldbox ()
├── testbox ()
├─┬ JSONPrettyPrint (1.3.3)
│ ├── coldbox ()
│ └── testbox ()
├─┬ adobe-password-util (1.0.8)
│ └── propertyFile ()
├── semver (1.1.3)
└── propertyFile (1.1.0)
update --system
Resolving Dependencies, please wait…
log4j:WARN No appenders could be found for logger (org.apache.http.client.protocol.RequestAddCookies).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
There are no outdated dependencies!
install commandbox-cfconfig
log4j:WARN No appenders could be found for logger (org.eclipse.jgit.util.FS).
log4j:WARN Please initialize the log4j system properly.-------------
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
✓ | Installing package [forgebox:commandbox-cfconfig]
✓ | Uninstalling package: commandbox-cfconfig
✓ | Installing package [forgebox:cfconfig-services@be]

✓ | Installing package [forgebox:lucee-password-util@^1.0.0]
✓ | Installing package [forgebox:adobe-password-util@^1.0.0]

✓ | Installing package [forgebox:propertyFile@^1.0.0]
✓ | Installing package [forgebox:propertyFile@^1.0.7]
✓ | Installing package [forgebox:semver@^1.0.0]
✓ | Installing package [forgebox:JSONPrettyPrint@^1.2.6]

Please sit tight while your shell reloads…

list --system
Dependency Hierarchy for (1.0.0)
└─┬ commandbox-cfconfig (1.0.0)
└─┬ cfconfig-services (1.0.3)
├── lucee-password-util (1.0.3)
├── coldbox ()
├── testbox ()
├─┬ JSONPrettyPrint (1.3.3)
│ ├── coldbox ()
│ └── testbox ()
├─┬ adobe-password-util (1.0.8)
│ └── propertyFile (1.1.0)
├── semver (1.1.3)
└── propertyFile (1.1.0)

`

I re-exported my server config and was able to import everything. Sorry it was so trivial, thanks for your help!

Glad to hear it’s working now for you!

Hi Brad, how do you set ColdFusion Class Path in server.json ? What is the name of the property? See the image attachment

This should do what you need:

https://commandbox.ortusbooks.com/embedded-server/configuring-your-server/adding-custom-libs

Note, that’s a server.json setting, not CFConfig.

Thank You Sir!