[ColdBox 3.6.0] How do you disable SES

Can someone tell or point me to instructions on how to disable SES.

I’ve tried commenting out the interceptor in config.cfc but I am getting an error saying htmlBaseURL is not defined.

On functions like setNextEvent will coldbox then switch to using this “index.cfm?event=Home.test” format? Right now it would do this “index.cfm\home\test”

I’m a little surprised that I have not received an answer to this. Most of the time I see responses pretty quick.

It was my understanding that the SES urls could be turned off. Is that no longer the case? Also I seem to remember reading something saying that without SES you had to use a different application CFC. but I may be getting my wires crossed.

At this point we will probably keep SES but I’d still like to know if it is possible.

It is possible, and if your getting that error then check the routes.cfc in case you removed something from there that yous shouldn’t have.

Last resort, restart ColdFusion or change the application name and see what you get. Let us know.

SES is controlled by one interceptor declared in your configuration file. Remove it and no more SES. It is in the docs :slight_smile:

That is what I did and I got the error.

I did exactly this and it didn’t disable. Pretty much NOTHING about coldbox views is working with tomcat and a subdirectory.

can someone please help me? this is really frustrating.

Do you have some rules in htaccess?

Can the OP explain exactly what they’re trying to do and exactly what isn’t working. What URLs are being hit, what result is expected, and what result is being obtained?



ColdBox/CommandBox Developer Advocate
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com