[coldbox-3.6.0] URLRewriteFilter and CF10


I think i have found a bug in CF10 and the URLRewriteFilter. I have had the same issue with FW/1 too (posted this similar question there too).

I am running on Windows Vista and CF10 development edition with the built in webserver. I’m not using any external webserver like apache etc.

Oh and I am using 10 with updater 8 (10,0,8,283965)

I downloaded the URLRewriteFilter and updated my web.xml and added the urlrewritefilter.xml.

I got the urlrewritefilter.xml example from the Coldbox examples.

So… I have a basic rule like so.

Generic Pretty URLs Pass-through ^/(index.cfm|robots.txt|osd.xml|flex2gateway|cfide|cfformgateway|railo-context|admin-context|files|images|js|javascripts|css|styles) \.(bmp|gif|jpe?g|png|css|js|txt|pdf|doc|xls|ico)$ ^/(.*)$ /index.cfm/$1

When i view any page now I get an “index.cf” not found. It seems to be screwing up something with the request or CGI vars or something.

I was wondering if anyone has tried this and received the same error.

It does look like a bug in ACF10 but not sure what is really happening to accurately log it as a bug.

Any help is appreciated!

Are you talking about the Tuckey Rewrite filter?

Yes Louis

UrlRewriteFilter - Rewrite URL's in Java Web Application Servers

this works fine in ACF but not with ACF10 running the built in webserver locally. If it is a bug in ACF I wanted to submit it

Works in ACF 9 not ACF 10 just to be clear.


This is what I use with CF10 and Tomcat:

However, I don’t use the embedded cf10 tomcat, I use a vanilla tomcat installation.

Luis Majano
Ortus Solutions, Corp

ColdBox Platform: http://www.coldbox.org
Linked In: http://www.linkedin.com/pub/3/731/483
Social: twitter.com/ortussolutions | twitter.com/coldbox | twitter.com/lmajano


Is there a link you can point me to on how to install tomcat and deploy cf10 as a war or how to set it up like that?

Hmm, I don’t think I kept instructions Mathew, but it was straightforward. Just when you install CF10, use the WAR approach. However, you will need to patch it as well.