ColdBox 3.6 - ORM DropCreate

Hi guys,

This is an ORM question, but I figured this would be the fastest place to get an answer. I’m puzzled by the following now working…

My ORM Settings:

// ORM Settings

this.ormEnabled = true;

this.datasource = “foo”

this.ormSettings =


dbcreate = “dropcreate”

,dialect = “MySQL”



,flushatRequestEnd = false

,automanagesession = false

,eventHandling = false


My DB connectivity is working fine, and I have no entity tables (except for cachebox and logbox).

In my base model folder I have a couple of non-persistent entities. In my modules/api/models folder I have a copule of non persistent entities, a service, and two persistent entities.

I’m using Railo 4 on OSX and my MYSQL db is local. When I run ?ORMReload=true in the URL it appears that something is happening, yet I don’t see any the entity tables being generated, or any errors produced in console or the browser. Any ideas what I might be doing wrong?



Actually hibernate generate ddl statements and in-case of any error it rollback transaction. so enable hibernate sql logging for error detail.

Also in some cases createdrop does not work properly as well.
Drop database manually and just use dbcreate = “update”

Hi Sana,

Do you (or anyone on the list) happen to know how to enable on Railo? I have logSQL set to true in my ORM settings and nothing is written to the console. I did a search for log4j and railo and the only thing I came across was this…!searchin/railo/log4j/railo/DqVNESM3Zo4/LEg0n63XNrUJ


Hi folks,

I did some more digging and I think I may have found a bug in Railo.

So in my app I had a frameworks folder, and within that folder I had my Coldbox folder and ValidateThis folder.

Within ValidateThis there was a samples folder and two ORM samples folders that both had User entities. In my ORM cfcLocation I also had a User entity. The crazy thing is that the validateThis folder pass was not referenced in the ORM cfcLocation setting in Application.cfc. So it seems like Railo was completely ignoring this setting and scanning then entire project.

When I deleted the samples folder all was fine and well and the dropcreate and update worked without issue.

Think it’s a bug? I’m going to post to the Railo list as well.