[Coldbox 4.2.0] - Debug mode does not work anymore in my application


When I first start using Coldbox setting debugmode = true in my Coldbox.cfc would work and activate the debugger. For some reason now it seems to have no affect. Is there something else anyone can think of that may be needed to get the coldbox debugger to show up other than setting the flag to true in the Coldbox.cfc file? I checked my environment settings and in fact removed them to eliminate that just to try to get it to work, but no luck.

Any assistance appreciated


Which version of coldbox ?

In coldbox 4+ debugger is as module


4.2.x… mentioned it in subject line :slight_smile:

Good to know though so that’s probably why it doesn’t work…

Well, what you didn’t mention is the version of ColdBox that you used to use back when the debugger worked, or if the debugger had necessarily quit working after the upgrade from 3.x to 4.x, etc, etc. If the debugger just worked yesterday and you haven’t changed anything then I don’t know what the issue is. If the debugger used to work back when you were on ColdBox 3.x, then you need to run “install cbdebugger” from CommandBox :slight_smile: Check out the readme in the module to see what the settings now look like.



ColdBox/CommandBox Developer Advocate
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com