CommandBox and routes with "files" in path

Maybe it’s my only functioning neuron… but I updated an application to CommandBox 6.

I have a route configured like this

route( "/files/:fileId" )
  .withAction( {
	 POST : "create",
	 PUT : "modify"
   }).toHandler( "FileController" );

(I also tried with other configurations - post().to() post().toHandler())

With CB 5 it worked correctly, with CB 6 it gives me a 404.
If I replace “files” in the route with anything else, it works fine.

This is the response markup:

<html><head><title>Error</title></head><body>Not Found</body></html>

I don’t have anything like this in my application, that’s why I’m thinking it’s CommandBox/Undertow.

I thought it was the “blocksensitivepaths” option that blocked a path with “files” in the name, but that doesn’t seem to be the case.

Any suggestions?

I’m not sure what CommandBox 6 would do to change how URLs are handled. I’d guess rewrites either aren’t enabled, or your app requires some custom rewrites. Can you show what the URL is yout hit? Are rewrites enabled? If you add the /index.cfm/ to the URL, does it change the behavior