[CommandBox v1.0.0] server start - invalid component definition, can't find component [coldbox.system.Coldbox]

I downloaded CommandBox v1.0.0 for Windows from http://www.ortussolutions.com/products/commandbox. I tried it first with No JRE since I assumed it would just use my JAVA_HOME ran into the same issue when using the download that includes the JRE as well.

I tried to run the server start command from my coldbox application directory. CommandBox opened up my app at but I get the following error.

Railo Error (expression)
Message invalid component definition, can’t find component [coldbox.system.Coldbox]
Stacktrace The Error Occurred in
/Application.cfc: line 31

29: // application start
30: public boolean function onApplicationStart(){
31: application.cbBootstrap = new coldbox.system.Coldbox( COLDBOX_CONFIG_FILE, COLDBOX_APP_ROOT_PATH, COLDBOX_APP_KEY, COLDBOX_APP_MAPPING );
32: application.cbBootstrap.loadColdbox();
33: return true;

Java Stacktrace invalid component definition, can’t find component [coldbox.system.Coldbox]
at railo.runtime.component.ComponentLoader.load(ComponentLoader.java:296):296
at railo.runtime.component.ComponentLoader.loadComponent(ComponentLoader.java:41):41
at railo.runtime.PageContextImpl.loadComponent(PageContextImpl.java:2893):2893
at railo.runtime.functions.other.CreateObject.doComponent(CreateObject.java:210):210
at railo.runtime.functions.other._CreateComponent.call(_CreateComponent.java:21):21
at application_cfc$cf.udfCall(/Application.cfc:31):31
at railo.runtime.type.UDFImpl.implementation(UDFImpl.java:92):92
at railo.runtime.type.UDFImpl._call(UDFImpl.java:306):306
at railo.runtime.type.UDFImpl.call(UDFImpl.java:207):207
at railo.runtime.ComponentImpl._call(ComponentImpl.java:623):623
at railo.runtime.ComponentImpl._call(ComponentImpl.java:506):506
at railo.runtime.ComponentImpl.call(ComponentImpl.java:1738):1738
at railo.runtime.listener.ModernAppListener.call(ModernAppListener.java:388):388
at railo.runtime.listener.ModernAppListener.onApplicationStart(ModernAppListener.java:266):266
at railo.runtime.PageContextImpl.initApplicationContext(PageContextImpl.java:2792):2792
at railo.runtime.listener.ModernAppListener._onRequest(ModernAppListener.java:101):101
at railo.runtime.listener.MixedAppListener.onRequest(MixedAppListener.java:18):18
at railo.runtime.PageContextImpl.execute(PageContextImpl.java:2218):2218
at railo.runtime.PageContextImpl.execute(PageContextImpl.java:2185):2185
at railo.runtime.engine.CFMLEngineImpl.serviceCFML(CFMLEngineImpl.java:332):332
at railo.loader.servlet.CFMLServlet.service(CFMLServlet.java:29):29
at javax.servlet.http.HttpServlet.service(HttpServlet.java:790):790
at io.undertow.servlet.handlers.ServletHandler.handleRequest(ServletHandler.java:85):85
at io.undertow.servlet.handlers.security.ServletSecurityRoleHandler.handleRequest(ServletSecurityRoleHandler.java:61):61
at io.undertow.servlet.handlers.ServletDispatchingHandler.handleRequest(ServletDispatchingHandler.java:36):36
at io.undertow.servlet.handlers.security.SSLInformationAssociationHandler.handleRequest(SSLInformationAssociationHandler.java:113):113
at io.undertow.servlet.handlers.security.ServletAuthenticationCallHandler.handleRequest(ServletAuthenticationCallHandler.java:56):56
at io.undertow.security.handlers.AbstractConfidentialityHandler.handleRequest(AbstractConfidentialityHandler.java:45):45
at io.undertow.servlet.handlers.security.ServletConfidentialityConstraintHandler.handleRequest(ServletConfidentialityConstraintHandler.java:61):61
at io.undertow.security.handlers.AuthenticationMechanismsHandler.handleRequest(AuthenticationMechanismsHandler.java:58):58
at io.undertow.servlet.handlers.security.CachedAuthenticatedSessionHandler.handleRequest(CachedAuthenticatedSessionHandler.java:70):70
at io.undertow.security.handlers.SecurityInitialHandler.handleRequest(SecurityInitialHandler.java:76):76
at io.undertow.server.handlers.PredicateHandler.handleRequest(PredicateHandler.java:25):25
at io.undertow.server.handlers.PredicateHandler.handleRequest(PredicateHandler.java:25):25
at io.undertow.servlet.handlers.ServletInitialHandler.handleFirstRequest(ServletInitialHandler.java:240):240
at io.undertow.servlet.handlers.ServletInitialHandler.dispatchRequest(ServletInitialHandler.java:227):227
at io.undertow.servlet.handlers.ServletInitialHandler.access$000(ServletInitialHandler.java:73):73
at io.undertow.servlet.handlers.ServletInitialHandler$1.handleRequest(ServletInitialHandler.java:146):146
at io.undertow.server.Connectors.executeRootHandler(Connectors.java:168):168
at io.undertow.server.HttpServerExchange$1.run(HttpServerExchange.java:727):727
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source):-1
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source):-1
at java.lang.Thread.run(Unknown Source):-1

Timestamp 9/19/14 12:52:22 AM MDT

This app was created as a blank AdvancedScript Sample ColdBox app following the steps Brad outlines his video on the aforementioned URL.

I even visited and tried setting a mapping to the coldbox folder for my app within this context but that didn’t seem to help.

Is this related to my java version? Running this:

java -version

results in


java version “1.7.0_45”
Java™ SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot™ 64-Bit Server VM (build 24.45-b08, mixed mode)


Any thoughts on what I might be missing here would be much appreciated.


Hi, that error simply means the server is running fine but can’t find the ColdBox framework. There are a couple ways to install it.

First you can use the –installColdBox flag that is part of the “coldbox create app” command

coldbox create app myApp --installColdBox

Secondly, you can just install ColdBox directly via the install command:

install coldbox

We did have a short window yesterday where our bleeding edge download had a bug that would cause it to output a warning tell you ColdBox was already installed and it would just create the empty folder. That has been fixed, but upgrade your installation just to be sure:

upgrade --latest

It might help if you wipe out the contents of your test directory just to have a fresh start too.

Note, you can also use the embedded server for ANY CFML application, not just ColdBox. Here is a valid experiment:

mkdir test
cd test
echo “#now()#” > index.cfm



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

Thanks Brad!

Well I’ve got it working now after wiping out my test directory and running the command below.

coldbox create app flows --installColdBox

However, in part what I was after was trying to install Coldbox 4, so I then emptied the directory and ran the following command instead.

coldbox create app flows --installColdBoxBE

I now remember, since it’s not so late, that this is what I did originally. However when running this command the error returns. I also thought that this was related to an artifact version of coldbox-be in my artifacts directory ( C:/User/Tim/.CommandBox/Artifacts ) so I deleted that folder to force CommandBox to re-download ColdBox BE. However, with a fresh download of BE using the above command checking the directory contents definitely shows that Coldbox.cfc is missing.

I’d like to checkout Coldbox 4 so any thoughts on what I’m doing wrong here would be appreciated. I also ran the upgrade --latest command within CommandBox


If you are installing ColdBox 4, you’ll need to use a 4.0-compatible site skeleton. Or, if you wanted, you could test out our compatibility docs by upgrading the 3.x skeleton :slight_smile:

Try this:

coldbox create app flows AdvancedScriptBE --installColdBoxBE

BTW, you should have been able to figure this out. The BE skeletons are covered in the command docs which you can access with this:

coldbox create app help

The latest HTML version of this same info can also be downloaded from our integration server:

And for what it’s worth, we also have the command docs published for web viewing on S3, but it’s not the bleeding edge, it’s the latest “stable” version.



ColdBox Platform Evangelist
Ortus Solutions, Corp

E-mail: brad@coldbox.org
ColdBox Platform: http://www.coldbox.org
Blog: http://www.codersrevolution.com

Thanks Brad and Luis for your quick replies, and all that you do for the CFML community. CommandBox is awesome and I’m sure it will only get better and better.

I’ll dig into the docs a bit more and I’ll admit I should have done that a bit more before posting.

I just came to tto see if anyone had experienced same issue. Retrospectively the inline help would have tipped me off that I needed a different template.