Commandbox won't install (Win 10 Pro)

Windows 10 Pro. I’ve tried both the JRE version and the one using the JRE installed, but flash a quick error after clicking box.exe.

The CommandBox folder is created, but nothing runs. This is what I was able to capture since it scrolls by very fast and then closes the command prompt window.

Open a cmd window in the same directory as box.exe and run “box” from inside of it. That will capture the error :slight_smile:

It would appear Lucee is trying to download something. Does your computer have an external internet connection? Also what version of CommandBox are you using?

I’ve attached the error output. Version is 4.70. Error is the same regardless of whether I use the JRE bundled version or standalone.

Yes, it has an internet connection (same machine that I downloaded CommandBox on).

commandbox_error.txt (14.2 KB)

As I suspected, the error is Lucee trying to download OSGI bundles and getting a connection refused. I have no idea why it would be trying to do that (it’s not supposed to) but there’s no way to disable it. I have no control over any of this since it’s all part of the Lucee engine. Do you have anything on your network that blocks HTTP traffic by chance?

No - I put my PC into the DMZ (it’s just an Xfinity router) and that didn’t work either. It installed fine at home but was hoping to continue learning ColdBox at the office too. Could it be something on the Lucee end?

Yes, it’s defo something on the Lucee end. That’s what I’ve been saying! :slight_smile: I honestly don’t know what to tell you. I really really hate the stupid auto-downloading features of Lucee. I’ve asked for them to be removed many times and there is even a ticket to remove it. To date, LAS has never addressed this issue, or put in a flag to turn it off so there’s nothing I can do about it. I’ve also been promised that a stable Lucee release would never download OSGI bundles since it would already have all the bundles it needs in the jar. However, as you can see, this is obviously not working right, but again I have no control over this even though I’ve been complaining about it literally for years at this point.

As far as why you seem alone in getting this error message-- who knows. There may be logs inside the .CommandBox/engine folder that give you more information but it’s really hard to say. I just started up a fresh CommandBox instance on my Windows 10 laptop and it started fine. My network monitor did appear to show crap being downloaded, but since Lucee’s console out logs still don’t work after many months of me complaining about that as well there’s no way for me to tell what was being downloaded. The application and deploy log don’t give any indication of what it was doing.

I was struggling with this as well and though that if I installed it on my home computer using the method where you set the install directory that I may be able to zip up the commandbox folder after install and plop it in my work PC in the same file path and run it.

Sure enough it worked!

Set the install path home directory in


I also adjusted my proxy settings before running for the first time just to make sure I wouldn’t be blocked there.

open CommandBox.json and add your proxy setup.


After running box.exe I got the command prompt Woot Woot!

I had the same issue and got around it by taking my personal computer install and zipping it up and deploying that to my work computer. I used the file to setup my install path so it would match where I was expecting to install it on my work PC. Once unzipped on my work computer I took a moment to setup my proxy information in CommandBox.json just in case there were additional issues there.