ContentBox v5.1 released!

Wanted to make an announcement that we have released ContentBox v5.1 now: What's New With 5.1.0 - ContentBox Modular CMS

The docs are getting a massive update and this release brings a lot of stability to the platform. Enjoy!


Hi, how can I fix this?

@Samall That command obviously doesn’t exist. Chances are you

  • Don’t have the ContentBox CLI module installed
  • Are typing the command wrong

Thanks that worked. I try to follow the steps at but the next error is this one:

I have created the database (cms_contentbox) and only the migration table was added.

What was the exception?
Which database did you choose?
What if you removed the table?

What I’m trying to do is install Contentbox using the commandbox. As writting on the wiki it should be easy, just some steps and there you go. Why is the install-wizard asking for migration scripts? This is my first installation. So now I have removed the migration-table and tried again. So when the question “Migration table not installed, do you want to install?” I choose NO. Again an error pops up telling me to install the migration script.

I’m using MSSQL.

I am trying to follow what you are doing. The migration is ran by the installer to verify your credentials and get you started. It should be run. But after it runs it should start up the server you chose as well.

You haven’t answered if the installer fails after the migration script. Or not. And if it does what’s the stacktrace?

Where can I find the stacktrace, or is the info on the screenshot enough info.

Ok i seeeeee now. It creates the Migration and then it tries to create it again. That’s so weird. Basically the first step which says the migration was created is working but then running them says it’s not working.

Is the table being creat3d in the actual database?
What version of mssql is this?

Does it exist after that final step?
If you can provide a video that would be great

Yes the cfmigrations table is created.
Microsoft SQL Server 2017 (RTM-CU28) (KB5008084) - 14.0.3430.2 (X64) Dec 17 2021 14:30:27 Copyright (C) 2017 Microsoft Corporation Web Edition (64-bit) on Windows Server 2019 Datacenter 10.0 (Build 17763: ) (Hypervisor) on Windows server 2016.

I can create a video, do that tomorrow.

Thanks. It will help a lot to see where this issue can be happening… I have to vent that making this work on multiple databases and multiple engines is a true pain for us. But with community assistance and help, we can do it,

Hi All,
Since I ran across this posting and am having a similar issue with the migrations table after upgrading from 5.0.3 to 5.2.0, I figured it would just be easier to post here.

The upgrade itself went fine but when I try to run contentbox:migrate:up I get this error.

I have tried deleting the cfmigrations table multiple times with the same issue. I haven’t taken a peek at the SchemaBuilder.cfc yet to see if there might be something obvious going. But I am more than happy to check that out and report back if that helps.

I’m using SQL Server 2019 with Lucee 5.3.9+133-SNAPSHOT. Anything else that might help troubleshoot I can send along as well.