[contentbox-version] Re: Contentbox Express Install error

Does catalina.sh have permissions and is it executable? You told us you did a chmod +rw but that doesn’t tell us who owns the file or if it is executable.



i tried running it in my webserver documents folder as well, but get same error.
i have coldbox devbox runnng though from the above folder.

Hi Brad
Thanks for your help.
I ran sudo chown with my username.
Here is the output i now get:

Marcus-Raath-Air:~ marcusraath$ sudo bash /Library/WebServer/Documents/cms/bin/startup.sh
Using CATALINA_BASE: /Library/WebServer/Documents/cms
Using CATALINA_HOME: /Library/WebServer/Documents/cms
Using CATALINA_TMPDIR: /Library/WebServer/Documents/cms/temp
Using JRE_HOME: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home
Using CLASSPATH: /Library/WebServer/Documents/cms/bin/bootstrap.jar:/Library/WebServer/Documents/cms/bin/tomcat-juli.jar
touch: /Library/WebServer/Documents/cms/logs/catalina.out: No such file or directory
/Library/WebServer/Documents/cms/bin/catalina.sh: line 392: /Library/WebServer/Documents/cms/logs/catalina.out: No such file or directory

It means it can’t write to the logs directory: /Library/WebServer/Documents/cms/logs/catalina.out

It needs permissions to write to there


Luis F. Majano
Ortus Solutions, Corp

ColdBox Platform: http://www.coldbox.org
Linked In: http://www.linkedin.com/pub/3/731/483
Blog: http://www.luismajano.com
IECFUG Manager: http://www.iecfug.com

Social: twitter.com/lmajano facebook.com/lmajano