ContentBox3 installation error on Windows, Lucee5, MSSQL


I’m running into error " could not insert: [cbPermission] " during ContentBox3 installation on Windows, Lucee5, MSSQL. (Attached screenshot for reference)
In Application.cfc, I have changed the ORM dialect = “SQLServer”, created Database and DataSource.
During execution on installer i’m getting " could not insert: [cbPermission] " error and I noticed that tables are not generated in the Database.
Can anyone tell me what I’m missing?

The Lucee orm dialect for MSSqlServer is MicrosoftSQLServer.


Thanks for your reply.
I have made dialect changes as per your comment. But still i’m getting same error.
Contentbox tables are not created in Database.

Does your user have the right permissions

Luis Majano
Ortus Solutions, Corp
P/F: 1-888-557-8057

Thanks Luis,

Tables got created in Master Database. After changing permissions everything is working fine.

Where is that permission?

I have the same problem

Contentbox is not certified to work on Lucee 5. Lucee 5 has tons of orm issues that need to be addressed by the lucee team. We have created reports and waiting on fixes by the lucee team.

Please use lucee 4.5 or any acf engine

Luis Majano
Ortus Solutions, Corp
P/F: 1-888-557-8057

But I use Lucee's CommandBox.

That’s fine use Lucee 4.5 or the default LUcee engine in CommandBox.

default LUcee engine in CommandBox

This is what I did and I am also getting this error …

  1. install contentbox-installer
  2. server start cfengine=lucee@4.5 --rewritesEnabled

App started in the browser, I provided all the details and “Enable Full URL Rewrites: ON (Commandbox”)

And got the below error … Can you please help ?

Oopsy! Something went wrong!Event: contentbox-installer:home.install

Routed URL: cbinstaller/install/
Layout: N/A (Module: )
View: N/A
Timestamp: 07/06/2017 06:14:16 PM


contentbox is not compatible with Lucee-5, as there are many pending hibernate ORM bugs in Lucee-5.

Use Lucee-4.5

I am using “cfengine=lucee@4.5”.

Getting same error on Lucee 4.5, Adobe CF2016, AdobeCF11. I check tables those are created and user has permission to insert into the cbpermission table. I will do a short video to show you. Thanks

Hi Guys, Here is some information to hopefully help you fix this error with the application trying to do an insert a duplicate value into the cb_permission table. The first thing you need to do is make sure you are using Lucee 4.5 and MySQL. There are some issues that need to be resolved for the MSSQL database and some supported Lucee code only.

  1. The first thing is make sure you start with a clean database. If you have ran the installer your database is not clean. Drop your database and create a new one.

  2. Next go to some files and do some edits there. Go to contentboxmodulesinstaller\contentbox-installer\views\home\steps line 21 and add the value attribute to the hidden field html help function set it to 0.
    name = “fullrewrite”,
    value = 0
    This will stop the error cannot convert a string to a boolean.

  3. start server open lucee admin set datasource if it is not already set

  4. Bring up another browser window and try and hit the site.

  5. When you are presented with the installer go to the database using some db tool take the unique constraint off of the cb_permissions table field permission field. Make sure you do that before you run the installer.

  6. Run the installer. Make sure you add dummy content. It does not work without it. You can delete it later.

  7. Once your site is loaded you will need to make false or true to the these values from the cb_settings table cb_site_ssl, cb_site_mail_ssl, cb_site_mail_tls. You will get errors when you delete or try and add pages. The toggles were not set correctly with default values.

This should get you going.


I have revised the installer yet again. Seems our move to toggle buttons created some havoc on 3.6.0. Can you please verify the bleeding edge installer?

box install contentbox-installer@be



Thanks George … I tried this bus was getting same issue.

“box install contentbox-installer@be” fixed it for me … Thanks Luis.

Thanks guys!!

Yogesh, please let me know if you find anything in the be release. I am winding it down to release it as 3.7