Error - The orm package is not installed


I’m using FW/1 with a CF instance through CommandBox. Everything has been working perfectly until I tried to use ORM and then got this error:

Error: Problem with metadata for user (model.objects.user) because: Unable to getComponentMetadata(model.objects.user) because: The orm package is not installed. (You can install package through CLI package manager (/Users/garyhouk/.CommandBox/server/0B6B9FFE2C8E7F20D6D9C98DF3FF0EEB-mydruminventory/adobe-2023.0.08.330668/WEB-INF/cfusion/bin/ by running the command : install orm.), near line 458 in /Users/garyhouk/Desktop/druminventory/framework/ioc.cfc

I figured this would be an easy fix, run ‘install orm’. However, when I run it I now get this error through CommandBox:

ERROR (6.0.0+00787)
Error getting ForgeBox entry [orm]
The entry slug sent is invalid or does not exist

What am I missing here? I just wanted to use orm with my project. Any help would be much appreciated.



There package you are looking for is an Adobe one. cfpm install orm

Since you are using Framework One instead of Coldbox, the cborm package on Forgebox would not be applicable

Thanks for the quick response! I literally just came across that and it is working now. Thank you sooo much! What awesome support.