Error upon actvating Slatwall-Contentbox module

Hi Box-ers, I downloaded from github. Unzip it %root%/modules/contentbox/modules directory. I renamed it to slatwall-contentbox. I clicked rescan button on module admin actions, then I saw Slatwall Connector Version 1.0 By ten24 Web Solutions. When I tried activating the module using the thumbs up button, I got an error. Please see attached jpeg. I’m digging in into contentbox ecommerce powers, I really appreciate any help.

Best regards,

As it requires ORM tables to be created, you will need to follow the instructions for installing that module.

Will try that. Thanks

I installed the stand alone Slatwall and worked fine. Tables are created. On Contentbox side I rescan modules then when I activate it I still get

Application Execution ExceptionError Type: Database : 42S02

Error Messages: Error Executing Database Query.
[Macromedia][SQLServer JDBC Driver][SQLServer]Invalid object name ‘SwFulfillmentMethod’.

Any idea what step I’m missing


In ContentBox, and I am not sure if it is using standard ContentBox module or ColdBox modules. The first thing I would be reading is the install instructions and whether there is anything about modifying the application.cfc to update the ORM or whether you need to reload the application etc.

Have you got a link to the module, or is this from Forgebox?

The readme is very clear on how to install this.

I followed all the instructions but I still get the same error :frowning:

ok, unless someone else helps out first. I’ll try to install it myself tomorrow or the next day and see how I go.

My guess in the meantime, is either change the application name after changing the application.cfc so it picks up the ColdFusion ORM changes and see how you go.

oops hit send to soon.

Or change the application name and restart ColdFusion itself to force the changes to happen.

I have never got that message before. That looks like a newer piece of slatwall. Can you see if you have a “SwFulfillmentMethod” table in your database and also check out the Slatwall/model/entity/FullfillmentMethod.cfc for errors.

What version of CMFL are you running?

Curt Gratz

I’m using cf10 from hostek hosting

Curt, SwFulfillmentMethod table exists.

I tried installing from ms sql to mysql, stand alone Slatwall admin ran fine then a new error came when i activate slatwall connector module. Please see attached jpeg

Hey all, sorry that I’m jumping into this thread so late. Could you please paste the entire stack trace of what you are seeing so that I can help?


Also in the future if you have issues or questions related to Slatwall, I wanted to let you know about the Slatwall google group which is very active and has a lot of developers who can help.


Thank you all guys all the help. Attached is the entire stack trace

stackError.pdf (3.85 MB)

Are you running Railo or ACF and what is its full version number?

Also, can you please post your Application.cfc contents.

I’m using ACF. This is my contentbox Application.cfc

You need to add the mapping for /Slatwall, I’m not seeing it in your application.cfc

Curt, can you confirm what the Application.cfc is supposed to look like?


Sorry for the delay in getting back to you, I was off of work the last few days.

The installer of the module should have wrote two lines just below your @cf9-error@ section of code in your app.cfc

//Slatwall Setup
this.mappings["/Slatwall"] = COLDBOX_APP_ROOT_PATH & “Slatwall”;

Please add those and report back.