Fusion Reactor Debugger in Command Box

Hi All,

I have Developer License for Fusion Reactor and am trying to get the debugger working from a CommandBox server. The FR docs say that the Developer edition should support it but I can’t seem to get the last step

so far I’m following https://docs.fusion-reactor.com/display/FR62/FusionReactor+Production+Debugger+Installation and have done:

  1. Installed the Commandbox Fusion Reactor

  2. Done FR Open and saw FR working

  3. Downloaded the Debugger / Native Libraries

  4. Copied the .dll to .CommandBox\server\B640724583E53AEA9502E4B736B075C4-debug2018_08_10\lucee-5.3.0-beta.86\fusionreactor

  5. I think the last piece is to put in the -agentpath JVM argument which I assume would be “-Dagentpath=C:\Users\djcar.CommandBox\server\B640724583E53AEA9502E4B736B075C4-debug2018_08_10\lucee-5.3.0-beta.86\fusionreactor\frjvmti_x64.dll” However, I put that in the server.json JVM.args which made FR not start and then in server.json using fusionreactor.agentpath=“C:\Users\djcar\.CommandBox\server\B640724583E53AEA9502E4B736B075C4-debug2018_08_10\lucee-5.3.0-beta.86\fusionreactor\debug2018_08_10\frjvmti_x64.dll” with no luck. (I’ve done server restart whenever I changed the server.json settings)

    The only thing I can’t seem to verify is that it’s running in 64bit mode which I assume it is but don’t know.

Anyone done this at all or have any suggestions?

I keep meaning to add support for the debugger dll to the module but it’s just annoying as there’s different libs per OS and FR’s downloads are sort of all over the place.

I’ve never really used the debugger but I know people have done it with this module and I believe they just added the JVm args to the server.json. I’m not sure what the exact syntax is but I’d have to see exactly what your server.json file looked like and what exact error you got when trying to do a “start --debug”.

Ah, well, the errors are solved in that a) I messed up the absolute path to the .dll and b) I wasn’t running 64bit. Both solved and now the .dll is showing up in the RunTime arguments in FR

-agentpath:C:\Users\djcar.CommandBox\server\B640724583E53AEA9502E4B736B075C4-debug2018_08_10\lucee-5.3.0-beta.86\fusionreactor\frjvmti_x64.dll -javaagent:C:/Users/djcar/.CommandBox/server/B640724583E53AEA9502E4B736B075C4-debug2018_08_10/lucee-5.3.0-beta.86/fusionreactor/fusionreactor.jar=name=debug2018_08_10,address=

However, I don’t see the Debug Icon in left hand menu in FR. All the examples have the -javaagent appearing before the -agentpath argument. Would that make a difference? Open to any thoughts.